Вход | Регистрация
 

Ввод на основании массива документов. ERP через расширение

Ввод на основании массива документов.  ERP  через расширение
Я
   Юзер123
 
27.08.20 - 10:28
Доброго времени.
Делаю возможность создания на основании массива документов План закупок одного Заказа поставщику. Делаю через расширение.  Документ создается таб часть заполняется.  Но.  Как отобразить в структуре подчиненности все документы из массива?

В расширение перенес общую форму "СтруктураПодчиненности" и в ней поменял

&Вместо("ОбъектыПоКритериюОтбора")
Функция моя_ОбъектыПоКритериюОтбора(ЗначениеКритерияОтбора)

но это работает если я  на основании 1-го делаю .  А как мне в реквизит ДокументОснование поместить несколько документов из массива?
   Юзер123
 
1 - 27.08.20 - 10:47
Аррр
   Юзер123
 
2 - 27.08.20 - 10:56
Сделал через таб часть. Спасибо
   Юзер123
 
3 - 28.08.20 - 12:22
Доброго времени.

Реализовал в расширении ввод на основании Плана закупок документа Заказ поставщику.

Делал через общую команду.
В интерфейсе в форме списка и форме документа кнопка ввод на основании отдельно появилась.  как ее в  меню ввод на основании перетащить.

Командная панель формы.Создать на основании  - Группа в общей команде.

Пробовал так

&После("ДобавитьКомандыСозданияНаОсновании")
Процедура хх_ДобавитьКомандыСозданияНаОсновании(КомандыСозданияНаОсновании, Параметры)
    Документы.ЗаказПоставщику.ДобавитьКомандуСоздатьНаОсновании(КомандыСозданияНаОсновании);
КонецПроцедуры



кнопка добавляется но работает не так как надо.

Менял так же

&После("ДобавитьКомандуСоздатьНаОсновании")
Функция хх_ДобавитьКомандуСоздатьНаОсновании()


    Если ПравоДоступа("Добавление", Метаданные.Документы.ПриемкаТоваровНаХранение) Тогда
        КомандаСоздатьНаОсновании = КомандыСозданияНаОсновании.Добавить();
        КомандаСоздатьНаОсновании.Обработчик = ?!?!?!?   - ТУТ КАК МОЮ ОБ/ЩУЮ КОМАНДУ УКАЗАТЬ?;
        КомандаСоздатьНаОсновании.Идентификатор = "ВВодНаОСнованииПланаЗакупок";
        КомандаСоздатьНаОсновании.Представление = ОбщегоНазначенияУТ.ПредставлениеОбъекта(Метаданные.Документы.ПриемкаТоваровНаХранение);
        КомандаСоздатьНаОсновании.РежимЗаписи = "Проводить";
        КомандаСоздатьНаОсновании.МножественныйВыбор = Истина;
        
        Возврат КомандаСоздатьНаОсновании;
        
    КонецЕсли;
    
    Возврат Неопределено;
КонецФункции
   Юзер123
 
4 - 28.08.20 - 12:45
как тут стало тихо.. Раньше так не было(
   Юзер123
 
5 - 28.08.20 - 13:43
ап
   FIXXXL
 
6 - 28.08.20 - 13:55
обработчик заполнения где лежит?
   Юзер123
 
7 - 28.08.20 - 13:58
(6) Общая команда.  Обработчик заполнения в Документе Заказ поставщику
   Юзер123
 
8 - 28.08.20 - 14:13
У документа План закупок в Вводе на основании есть только "Задача" .. И моя  общая команда добавляется не строчкой в меню Ввод на основании" а как новая енопка.
   Юзер123
 
9 - 28.08.20 - 14:13
Хотя в ней указано 

Командная панель формы.Создать на основании  - Группа в общей команде.
   FIXXXL
 
10 - 28.08.20 - 16:06
(7)
в случае
    Если ПравоДоступа("Добавление", Метаданные.Документы.ПриемкаТоваровНаХранение) Тогда
        КомандаСоздатьНаОсновании = КомандыСозданияНаОсновании.Добавить();
        КомандаСоздатьНаОсновании.Обработчик = ?!?!?!?   - ТУТ КАК МОЮ ОБ/ЩУЮ КОМАНДУ УКАЗАТЬ?;
        КомандаСоздатьНаОсновании.Идентификатор = "ВВодНаОСнованииПланаЗакупок";
        КомандаСоздатьНаОсновании.Представление = ОбщегоНазначенияУТ.ПредставлениеОбъекта(Метаданные.Документы.ПриемкаТоваровНаХранение);
        КомандаСоздатьНаОсновании.РежимЗаписи = "Проводить";
        КомандаСоздатьНаОсновании.МножественныйВыбор = Истина;
        
        Возврат КомандаСоздатьНаОсновании;
        
    КонецЕсли;

в кнопке указывается .Обработчик, если тебе нужен обработчик, отличный от типовой процедуры заполнения

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.