Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не показывает вопрос в "Управляемых формах" при открытии из дополнительных обработок.

Не показывает вопрос в "Управляемых формах" при открытии из дополнительных обработок.
Я
   Fredy72
 
26.08.20 - 15:54
Добрый день!
Конфигурация УТ11(11.4.8.84) Управляемые формы.
Есть внешняя обработка, где в сведениях о внешней обработке добавлена одна команда с СтрокаКоманды.Использование = "ОткрытиеФормы"
В процедуре "При открытии" формы есть вызов процедуры ПроверитьДанныеЗаполнения()

&НаКлиенте
Процедура ПроверитьДанныеЗаполнения()
    Оповещение = Новый ОписаниеОповещения("ПослеОтветаНаВопросДанныеЗаполнения",ЭтотОбъект);
    ПоказатьВопрос(Оповещение, "Обнаружены данные прошлого заполнения!
    |Заполнить таблицу этими данными? ",  РежимДиалогаВопрос.ДаНет);
КонецПроцедуры

&НаКлиенте
Процедура ПослеОтветаНаВопросДанныеЗаполнения(Результат, Параметры) Экспорт
    
    Если Результат = КодВозвратаДиалога.Да Тогда
        ЗаполнитьНоменклатуру2(Неопределено);
    ИначеЕсли Результат = КодВозвратаДиалога.Нет Тогда
        ОчиститьДанныеЗаполнения(Новый Структура("СкладРЦ,СкладМагазин",СкладРЦ,СкладМагазин));
    КонецЕсли;
    
    а=5/0;    //тут вызывается ошибка и ругается что деление на 0
    
КонецПроцедуры

Если данную обработку вызвать из "Файл\Открыть", тогда все ОК.
Но если я ее добавляю в "Дополнительные обработки" и вызываю из указанного интерфейса, тогда вопрос не вызывается, но при этом в процедуру оповещения программа попадает (срабатывает ошибка деления на 0).
Подскажите пожалуйста почему при добавлении обработки в "Дополнительные обработки" игнорируется команда ПоказатьВопрос?
   lodger
 
1 - 26.08.20 - 16:05
ЭтаФорма попробуй написать.
   Андроны едут
 
2 - 26.08.20 - 16:13
Нужна такая процедура в модуле объекта:

Процедура ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт
    
    Настройки.ФормироватьСразу = Истина;
    Настройки.События.ПриОткрытии = Истина;
    
КонецПроцедуры
   Fredy72
 
3 - 26.08.20 - 16:15
(1)Пробовал все равно игнорирует.
   Fredy72
 
4 - 26.08.20 - 16:20
(2) Не прокатило. Спасибо за подсказку! Буду ковырять в этом направлении.
   Андроны едут
 
5 - 26.08.20 - 16:28
(4) ОпределитьНастройкиФормы = Истина;
   Fredy72
 
6 - 26.08.20 - 16:37
(5) Это где надо указать?
Данные параметры наверно присутствуют в формах отчетов, а у меня обработка.
   Fragster
 
7 - 26.08.20 - 16:38
может тупо в однократную обработку ожидания перенести?
   Андроны едут
 
8 - 26.08.20 - 16:54
(6) в сведениях о внешней обработке
   Fredy72
 
9 - 26.08.20 - 17:15
(8) Нет не получилось. Добавил в сведения о внешней обработке ОпределитьНастройкиФормы = Истина и в модуле объекта указал процедуру ОпределитьНастройкиФормы(Форма, КлючВарианта, Настройки) Экспорт
   Fredy72
 
10 - 26.08.20 - 19:13
(7) Так и сделал. Через обработку ожидания все работает. Спасибо! Не понятно только почему та же процедура не работает при простом вызове из "При открытии"

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.