Вход | Регистрация
 

Конвертация данных, как переопределить счет в плане счетов при выгрузке?

Конвертация данных, как переопределить счет в плане счетов при выгрузке?
Я
   Бешеный заяц
 
26.08.20 - 09:37
В базе источнике 43 счет разбит на 43.1, 43.2, 43.3 причем разбитие производили в режиме предприятия, в базе приемнике существует только  один 43 счет.
нужно в ПКО Хозрасчетный или в при выгрузке или перед выгрузкой сделать вроде
Если Источник.Код = "43.1" или  Источник.Код = "43.2" или  Источник.Код = "43.3" Тогда
Источник = Планысчетов.Хозрасчетные.ПланыСчетов.Хозрасчетный.ГотоваяПродукция;
КонецЕсли;

Как и где это прописать? причем это надо в ПКО плана счетов чтобы в каждом документе не писать в полях условие с присвоение"Значение = Планысчетов.Хозрасчетные.ПланыСчетов.Хозрасчетный.ГотоваяПродукция"
   PuhUfa
 
1 - 26.08.20 - 09:43
(0) Если ты это пропишешь в ПКО плана счетов то это будет работать только при обмене самого плана счетов. В документах все останется как есть
   Lexandr
 
2 - 26.08.20 - 09:48
Сделай поиск по КодБыстрогоВыбора. Если Источник.КодБыстрогоВыбора = "43.1" Тогда Значение = "43" КонецЕсли.
   Бешеный заяц
 
3 - 26.08.20 - 09:59
(1) так в документах напротив счета указано выгружать по правилу "Хозрасчетный" соответственно предполагаю в этих самих правилах "Хозрасчетный" можно переопределить источник по условию, или я неправ?
параметр "Источник " доступен для записи в ПКО? те его можно переопределить?
   Бешеный заяц
 
4 - 26.08.20 - 10:03
(2) возможно даже буду проверять через ПринадлежитЭлементу так проще, мне все еще мучает вопрос, возможно ли в  "ПКО" хозрасчетный переопределить Источник ?
   Mihasya
 
5 - 26.08.20 - 10:08
в ПКО "Хозрасчетный" в ПКС "Код" в обработчике "ПередВыгрузкой" напиши:
 
Если Лев(Источник.Код  ,2) = "43" Тогда
  Значение = "43";
КонецЕсли;

ну и соответственно поиск по коду должен быть
   SamHinkie
 
6 - 26.08.20 - 10:10
(4) чтобы переопределить источник, нужно в ПКС документа сделать структуру и передавать её в ПКО.
не понятно только зачем, если в 2 и 5 уже написали работающие решения?
а что это за принадлежитЭлементу?
   Бешеный заяц
 
7 - 26.08.20 - 10:13
(5) а понял спасибо
   hhhh
 
8 - 26.08.20 - 10:14
(6) зачем переопределять, если можно просто определить. В ПКЗ написать несколько строчек
   SamHinkie
 
9 - 26.08.20 - 10:16
(8) я отвечал на вопрос из 4, как "Переопределить".
   Lexandr
 
10 - 26.08.20 - 10:22
(2) Оговорился, конечно в пкс.
   Бешеный заяц
 
11 - 26.08.20 - 10:33
(6) да уже делаю как написали спасибо, а на будущее можно как то более "Кошерно" можно сделать? может получиться ситуация что подобный фокус не получиться в будущем.
Знаю только вариант в каждом документе где план счетов используется "Значение" для поле Счет переопределять по условию и все.
   DJ Anthon
 
12 - 26.08.20 - 10:42
будь мужиком, объедини счета

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.