Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

переменная с таблицей значения

переменная с таблицей значения
Я
   bfss-732
 
23.08.20 - 19:57
Всем привет!
Есть переменная, в которой есть таблица значений
ТаблицаТовары          = ОбеспечениеСервер.ТаблицаОстатковКЗаказу(ЗаказКлиента, ПараметрыТаблицыТовары);

МНЕ ДО ЗАГРУЗКИ В ТОВАРЫ(НИЖЕ) НАДО "ПРИКЛЕИТЬ" ЕЩЕ 5 КОЛОНОК С ЗНАЧЕНИЯМИ (которые получил в запросе в таблицу значений) К ПЕРЕМЕННОЙ ТаблицаТоваров.
В табличной части Товары уже есть все реквизиты, чтоб принять "приклеенные" значения.

Есть табличная часть Товары, куда все записывается
Товары.Загрузить(ТаблицаТовары);


Как правильно сделать?
Все взял из Процедура ЗаполнитьДокументНаОснованииЗаказа(Знач ЗаказКлиента)
МодульОбъекта ЗаказПоставщику Управление торговлей, редакция 11 (11.4.9.70)
   icipher
 
1 - 23.08.20 - 20:11
ТаблицаТовары.Колонки.Вставить("ИмяКолонки")
   icipher
 
2 - 23.08.20 - 20:13
(1)
ТаблицаТовары.Колонки.Добавить("ИмяКолонки")
ТаблицаТовары.ЗаполнитьЗначения(...)
ТаблицаТовары.ЗагрузитьКолонку(...)
и т. д.
   bfss-732
 
3 - 23.08.20 - 20:31
Ставлю точку после ТаблицаТовары. подсказки не выходит, это смутило
   ДенисЧ
 
4 - 23.08.20 - 20:36
(3) А откуда 1с узнает, какой тип у тебя возвращается из какой-то левой (для неё) функции?
   Ненавижу 1С
 
5 - 23.08.20 - 20:59
(3) нетипизированный язык, отсюда всё
   bfss-732
 
6 - 23.08.20 - 22:23
Как сделать чтоб каждая строка не перезаписывалась? Получается все строки заполняются последним значением из ВыборкаДетальныеЗаписи
Для Каждого Строка Из ТаблицаТовары Цикл
            
   Для Каждого Элемент Из ВыборкаДетальныеЗаписи Цикл
                
      ЗаполнитьЗначенияСвойств(Строка, Элемент);
                
                
   КонецЦикла;
            
КонецЦикла;
   acht
 
7 - 23.08.20 - 22:38
Ты сначала задайся вопросом - какая строка выборки какой строки таблицы соответствует. Одинаковый ли у них порядок, например, и почему нет
   bfss-732
 
8 - 23.08.20 - 22:45
(7) Есть строка "ТаблицаТовары", есть результат запроса ТЗ "ВыборкаДетальныеЗаписи". Для каждой строки "ТаблицаТовары" соответствует строка из "ВыборкаДетальныеЗаписи"
   bfss-732
 
9 - 23.08.20 - 22:46
Все идет правильно, просто последняя строка Элемент Из ВыборкаДетальныеЗаписи перетирает все 4 предыдущие строки. Получается в нужных колонках, в каждой строке из 4 одинаковые значения
   acht
 
10 - 23.08.20 - 22:46
(8) В запросе, порождающем выборку есть УПОРЯДОЧИТЬ ПО?
   bfss-732
 
11 - 23.08.20 - 22:49
(10) нет, а это причем?
   acht
 
12 - 23.08.20 - 22:52
(11) Ну все, порядок строк в выборке - произвольный, зависит от настроения сервера. Поэтому строки в выборке и таблице - несопоставимы. Присваивая значения, ты просто портишь данные.
   bfss-732
 
13 - 23.08.20 - 22:53
(12) Какой порядок нужен? АВТОУПОРЯДОЧИВАНИЕ подойдет?
   bfss-732
 
14 - 23.08.20 - 22:55
Порядок не помог
   acht
 
15 - 23.08.20 - 22:56
(13) > Какой порядок нужен?
Понятия не имею.
   Ненавижу 1С
 
16 - 24.08.20 - 00:22
Для Каждого Строка Из ТаблицаТовары Цикл
            
   НайденныеСтроки = ВыборкаДетальныеЗаписи.НайтиСтроки(...);
   Если НайденныеСтроки.Количество()>0 Тогда
     ЗаполнитьЗначенияСвойств(Строка, НайденныеСтроки[0]);
            
КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
Оптимист верит, что мы живем в лучшем из миров. Пессимист боится, что так оно и есть.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.