Вход | Регистрация
 

Программный вызов отчета на СКД запоминает старые настройки

Программный вызов отчета на СКД запоминает старые настройки
Я
   Chameleon1980
 
21.08.20 - 19:59
Приветствую всех.
Чет победить не могу.

&НаКлиенте
Процедура МНВ_Т5_ДляКадровогоПереводаСпискомТ5После(Команда)
    
    Ссылка=Элементы.Список.ТекущиеДанные.Ссылка;
    
    ПараметрыФормы = Новый Структура("СформироватьПриОткрытии", Истина);
    
    Форма = ПолучитьФорму("Отчет.ПечатнаяФормаТ5.Форма", ПараметрыФормы);
    
    Настройки = ПолучитьНастройки(Форма.Отчет.КомпоновщикНастроек);
    
    СсылкиНаОбъекты=Настройки.ПараметрыДанных.Элементы.Найти("СсылкиНаОбъекты");
    СсылкиНаОбъекты.Использование=Истина;
    СсылкиНаОбъекты.Значение=Ссылка;
    
    Форма.Отчет.КомпоновщикНастроек.ЗагрузитьНастройки(Настройки);
    
    Форма.СкомпоноватьРезультат();

    Форма.Открыть();

КонецПроцедуры

в очередной раз передаю в СсылкиНаОбъекты.Значение=Ссылка;
ссылку на другой документ, а он собака мне старые настройки какие-то подставляет.
пока не нажмешь стандартные настройки.

Что нужно добавить в параметры вызова, чтобы настройки старые не всплывали?
спасибо.
   Chameleon1980
 
1 - 21.08.20 - 20:38
&НаСервереБезКонтекста
Функция ПолучитьНастройки(КомпоновщикНастроек)
    
    Настройки = КомпоновщикНастроек.ПолучитьНастройки();
    Возврат Настройки;
    
КонецФункции
   youalex
 
2 - 22.08.20 - 00:12
А если так:

&НаКлиенте
Процедура ПечатьТ5(Команда)
    
    ПараметрыФормы = Новый Структура("СформироватьПриОткрытии", Истина);
    ПараметрыФормы.Вставить("КлючВарианта", "Т5");
    ПараметрыФормы.Вставить("Отбор", Новый Структура("СсылкаНаОбъект", Элементы.Список.ТекущиеДанные.Ссылка));
    
    ОткрытьФорму("Отчет.ПечатнаяФормаТ5.Форма", ПараметрыФормы);
    
КонецПроцедуры

   Chameleon1980
 
3 - 22.08.20 - 09:08
блин да работает
только
СсылкиНаОбъекты
но вопрос из (0) все еще интересует
   Chameleon1980
 
4 - 22.08.20 - 09:08
(2) спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.