Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Печатные формы

Печатные формы
Я
   YavorZayadlo
 
20.08.20 - 15:43
Добрый день!
Подскажите, пожалуйста, почему в итогах сумма не по отдельному столбцу, а по всему документу идет?
Для каждого стр из Картридж Цикл             
  Движения=Пакет[3].Выгрузить();        
   Для каждого стрДвижения Из Движения Цикл
    ОбластьИтогоНаименование.Параметры.Всего = Движения.Итог("Количество");            
   КонецЦикла;
ТабДок.Присоединить(ОбластьИтогоНаименование);
КонецЦикла;
   1Сергей
 
1 - 20.08.20 - 15:46
лолшто
   YavorZayadlo
 
2 - 20.08.20 - 15:49
Че совсем трэш?))
   1Сергей
 
3 - 20.08.20 - 15:53
Для каждого стрДвижения Из Движения Цикл
    ОбластьИтогоНаименование.Параметры.Всего = Движения.Итог("Количество");            


вот эти две строчки очень треш, да.
Чего сделать-то надоть?
   YavorZayadlo
 
4 - 20.08.20 - 16:02
Всего то нужно вывести итоги в таблице, но макет, для меня, сложный, поэтому туплю(

//1 Вывод области ОбластьКартриджиШапкаНаименование и ОбластьКартриджиШапкаФорма         

        ДанныеКартриджа = Пакет[1].Выбрать();
        Пока ДанныеКартриджа.Следующий() Цикл
            ОбластьКатриджыШапкаНаименование.Параметры.НаименованиеКартриджа = ДанныеКартриджа.НаименованиеКартриджа;
            ТабДок.Присоединить(ОбластьКартриджиШапкаНаименование);
        КонецЦикла;
        ТабДок.Присоединить(ОбластьКартриджиШапкаФорма);                
        //2 Вывод области ОбластьКартриджиШапкаНаименование и ОбластьКартриджиШапкаФорма 

        
        //1 Вывод области ОбластьОтветственныйСтолбец                 

        ДанныеТаблицы = Пакет[2].Выгрузить();
        
        ФИО = ДанныеТаблицы.Скопировать();
        ФИО.Свернуть("ОтветственныйПользователь","");
        //ФИО.Свернуть("ОтветственныйПользователь возр");

        Для Каждого стр Из ФИО Цикл
            ОбластьОтветственныйСтолбец.Параметры.ФИОполучателя = стр.ОтветственныйПользователь;
            ТабДок.Вывести(ОбластьОтветственныйСтолбец);        
            ДанныеКартриджа = Пакет[1].Выбрать();
            Пока ДанныеКартриджа.Следующий() Цикл
                СтруктураПоиска=Новый Структура();
                СтруктураПоиска.Вставить("ОтветственныйПользователь",стр.ОтветственныйПользователь);
                СтруктураПоиска.Вставить("НаименованиеКартриджа",ДанныеКартриджа.НаименованиеКартриджа);
                Массив = ДанныеТаблицы.НайтиСтроки(СтруктураПоиска);
                Если Массив.Количество()=0 Тогда
                            ОбластьОтветственныйНаименование.Параметры.Количество="";                
                            ТабДок.Присоединить(ОбластьОтветственныйНаименование);                            
                Продолжить;    
            КонецЕсли;
                ОбластьОтветственныйНаименование.Параметры.Количество="";                
                Для Каждого СтрМассив Из Массив Цикл
                     ОбластьОтветственныйНаименование.Параметры.Количество = СтрМассив.Количество;
                     ТабДок.Присоединить(ОбластьОтветственныйНаименование);
                 КонецЦикла;
            КонецЦикла;
             ТабДок.Присоединить(ОбластьОтветственныйФорма);
         КонецЦикла;         
        //2 Вывод области ОбластьОтветственныйСтолбец    

                 
        ТабДок.Вывести(ОбластьИтогоСтолбец);
   YavorZayadlo
 
5 - 20.08.20 - 16:05
Вот этот кусочек работает как надо, но дальше начинается беда, в подвале нужно вывести итоги

Список тем форума
Рекламное место пустует  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.