Вход | Регистрация
 

Этикетка ШК

Этикетка ШК
Я
   НатГолубева777
 
20.08.20 - 11:21
Добрый день!

Создала макет, в нем в т.ч. 2 картинки (QR код и EAN13). Сейчас 2 картинки отображаются как QR код. И понятно по логике программы. Помогите сделать 1 картинку как QR код и 2 ую как EAN13.

Макет         = УправлениеПечатью.МакетПечатнойФормы("Документ.ЗаказНаЭмиссиюКодовМаркировкиСУЗ.ПФ_MXL_ЭтикеткаОбувь");
        
    Эталон = УправлениеПечатью.МакетПечатнойФормы("ОбщийМакет.ЭталонИС");
    КоличествоМиллиметровВПикселе = Эталон.Рисунки.Квадрат100Пикселей.Высота / 200;
    
    Область = Макет.ПолучитьОбласть(Макет.ОбластьПечати.Имя);
    
    
    ПредыдущаяСтрокаПечати = Новый Структура("Номенклатура, Характеристика, GTIN");
    
    Для Каждого СтрокаДанных Из ТаблицаОбъектыПечати Цикл
        
        ИспользоватьХарактеристики = ОбщегоНазначенияКлиентСервер.ЕстьРеквизитИлиСвойствоОбъекта(СтрокаДанных, "Характеристика");
        
            Для НомерЭкземпляра = 1 По СтрокаДанных.Количество Цикл
            
            Если СтрокаДанных.ЭтоКодМаркировки Тогда
                
                Область = Макет.ПолучитьОбласть(Макет.ОбластьПечати.Имя);
                Если СтрокаДанных.ТипШтрихкода = Перечисления.ТипыШтрихкодов.DataMatrix Тогда
                    ТипКода = 18;
                ИначеЕсли СтрокаДанных.ТипШтрихкода = Перечисления.ТипыШтрихкодов.GS1_DataMatrix Тогда
                    ТипКода = 24;
                КонецЕсли;
                
                Область.Параметры.Наименование = СтрокаДанных.ПредставлениеНоменклатуры;
                
                                                                
            Иначе
                //////////////////
            КонецЕсли;
            
            Если СтрокаДанных.ШтрихкодВBase64 Тогда
                ТипВходныхДанных = 1;
                Штрихкод         = СтрокаДанных.Штрихкод;
            Иначе
                ТипВходныхДанных = 0;
                Штрихкод         = ШтрихкодированиеИС.КодGS1ДляКомпонентыПечати(СтрокаДанных.Штрихкод, ТипКода);
            КонецЕсли;
            
            Для Каждого Рисунок Из Область.Рисунки Цикл
                
                Область.Параметры.ПредставлениеШтрихкода = СтрокаДанных.КодМаркировки;
                
                ПараметрыШтрихкода = Новый Структура;
                ПараметрыШтрихкода.Вставить("Ширина",           Окр(Область.Рисунки.Ширина / КоличествоМиллиметровВПикселе));
                ПараметрыШтрихкода.Вставить("Высота",           Окр(Область.Рисунки.Высота / КоличествоМиллиметровВПикселе));
                ПараметрыШтрихкода.Вставить("Штрихкод",         Штрихкод);
                ПараметрыШтрихкода.Вставить("ТипВходныхДанных", ТипВходныхДанных);
                ПараметрыШтрихкода.Вставить("ТипКода",          ТипКода);
                ПараметрыШтрихкода.Вставить("ОтображатьТекст",  Истина);
                
                                                
                Область.Рисунки.Картинка = МенеджерОборудованияВызовСервера.ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода);
                                        
            КонецЦикла;
            
        КонецЦикла;

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.