Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не выполняется пакет запросов по причине синтаксической ошибки

Не выполняется  пакет запросов по причине синтаксической ошибки
Я
   1сЮлия
 
19.08.20 - 15:42
Добрый день! Не выполняется  пакет запросов по причине синтаксической ошибки   |ТаблицаТовары.Номенклатура,Функция ТекстЗапросаТаблицаТоварыНаСкладах()
        

    ТекстЗапроса = "ВЫБРАТЬ
                   |    ЗНАЧЕНИЕ(ВидДвиженияНакопления.Приход) КАК ВидДвижения,
                   |    ТаблицаТовары.Номенклатура КАК Номенклатура,
                   |    ТаблицаТовары.Количество КАК Количество,
                   |    ТаблицаТовары.Ссылка.Дата КАК Период,
                   |    ТаблицаТовары.Ссылка.Склад
                   |ИЗ
                   |    Документ.ПоступлениеТоваров.Товары КАК ТаблицаТовары";
    
    Возврат ТекстЗапроса;
    
КонецФункции


Функция ТекстЗапросаТаблицаЦеныНоменклатуры()
    

    ТекстЗапроса = "ВЫБРАТЬ
                   |    ТаблицаТовары.Номенклатура,
                   |    ТаблицаТовары.Цена,
                   |    ТаблицаТовары.Ссылка.ТипЦены,
                   |    ТаблицаТовары.Ссылка.ТипЦены.ВалютаЦены
                   |ИЗ
                   |    Документ.ПоступлениеТоваров.Товары КАК ТаблицаТовары";
    
    Возврат ТекстЗапроса;
    


КонецФункции


Процедура ИнициализироватьДанныеДокумента(ДокументСсылка, ДополнительныеСвойства) Экспорт
    
    ////////////////////////////////////////////////////////////////////////////
    // Создадим запрос инициализации движений
    
    Запрос = Новый Запрос;
    //ЗаполнитьПараметрыИнициализации(Запрос, ДокументСсылка);
    
    ////////////////////////////////////////////////////////////////////////////
    // Сформируем текст запроса
    
    ТекстыЗапроса = Новый СписокЗначений;
    ТекстыЗапроса.Добавить(ТекстЗапросаТаблицаТоварыНаСкладах(),"ТаблицаТоварыНаСкладах");
    ТекстыЗапроса.Добавить(ТекстЗапросаТаблицаЦеныНоменклатуры(),"ТаблицаЦеныНоменклатуры");
    
    Запрос.Текст = "";
    Для Каждого ТекстЗапроса из ТекстыЗапроса Цикл
        Запрос.Текст = Запрос.Текст + ТекстЗапроса.Значение;
    КонецЦикла;
    
    ////////////////////////////////////////////////////////////////////////////
    // Выполним запрос
    
    Результат = Запрос.ВыполнитьПакет();
    
    ////////////////////////////////////////////////////////////////////////////
    // Поместим результаты запроса в дополнительные свойства
    
    Для Каждого ТекстЗапроса из ТекстыЗапроса Цикл
        
        ИмяТаблицы = ТекстЗапроса.Представление;
        
        Если Не ПустаяСтрока(ИмяТаблицы) Тогда
            
            Индекс = ТекстыЗапроса.Индекс(ТекстЗапроса);
            ДополнительныеСвойства.ТаблицыДляДвижений.Вставить(ИмяТаблицы, Результат[Индекс].Выгрузить());
            
        КонецЕсли;
   vicof
 
1 - 19.08.20 - 15:43
; забыла
   1сЮлия
 
2 - 19.08.20 - 16:21
Где именно?
   ДенисЧ
 
3 - 19.08.20 - 16:23
(2) В каждом запросе
   1сЮлия
 
4 - 19.08.20 - 16:33
Я поняла,все работает.Спасибо большое!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.