Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как заполнить структуру в цикле?

Как заполнить структуру в цикле?
Я
   Mechanik21
 
19.08.20 - 14:34
ясно что не так
Для каждого Категория Из ТЗКатегорийПайщиков Цикл
    СтруктураКатегорийПайщиков = Новый Структура;
    СтруктураКатегорийПайщиков.Вставить("ИмяКатегории", Категория.ИмяКатегории);
КонецЦикла;
и не так
СтруктураКатегорийПайщиков = Новый Структура;
Для каждого Категория Из ТЗКатегорийПайщиков Цикл
    СтруктураКатегорийПайщиков.Вставить("ИмяКатегории", Категория.ИмяКатегории);
КонецЦикла;
А как?
   youalex
 
1 - 19.08.20 - 14:44
vanga mode on

СтруктураКатегорийПайщиков = Новый Структура;
Для каждого Категория Из ТЗКатегорийПайщиков Цикл
    СтруктураКатегорийПайщиков.Вставить(Категория.ИмяКатегории, Категория.Категория);
КонецЦикла;

vanga mode off

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.