Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Вопрос про директиву #Если

Вопрос про директиву #Если
Я
   s-n-a-y
 
18.08.20 - 17:18
Есть документ ЗаказПоставщику. Он может проводиться как в самой базе, так и через внешнее соедиенение. Но в случае внешнего соединения кусок кода не должен выполнятся. Делаю так

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)

    // ...    

    #Если ТолстыйКлиентОбычноеПриложение Тогда
        Если Номер_ERP = "" Тогда
            Для каждого СтрТЧ Из Товары Цикл
                СтрТЧ.КоличествоПоДокументу = СтрТЧ.Количество;
                СтрТЧ.ЕдИзмПоДокументу = СтрТЧ.ЕдиницаИзмерения;
                СтрТЧ.ЦенаПоДокументу = СтрТЧ.Цена;
            КонецЦикла;  
        КонецЕсли;        
    #КонецЕсли
    
КонецПроцедуры // ПередЗаписью

Надежно ли использовать для этих целей директиву #Если. Могут ли возникнуть какие-либо проблемы?
   Жан Пердежон
 
1 - 18.08.20 - 17:21
я бы через доп.свойства делал
   s-n-a-y
 
2 - 18.08.20 - 17:26
(1) ну тоже вариант, подумаю
   Вафель
 
3 - 18.08.20 - 19:01
лучше в форме флаг выставлять
   Вафель
 
4 - 18.08.20 - 19:02
или вообще в форме перед записью данный код вызывать
   s-n-a-y
 
5 - 18.08.20 - 19:31
(4) кстати да, это решение

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.