Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Двойной заход в цикл

Двойной заход в цикл
Я
   LittlePumpkin
 
17.08.20 - 20:17
Написал цикл в процедуре, прохожу его в дебаггере и вижу вот что: заходим в цикл, пробегаем его, выходим из цикла, доходим до слов "КонецПроцедуры" иии.... снова заходим в цикл! Что это за фигня и почему так происходит?
   Momus
 
1 - 17.08.20 - 20:22
мб эта процедура вызывается в цикле?) Если уверен в коде, то очистка кэша не помешает. Для начала можно привести код
   LittlePumpkin
 
2 - 17.08.20 - 20:23
Процедура Расш1_ПриОткрытииПосле(Отказ)

Для каждого итератор из Объект.Товары Цикл
    итератор.ПроцентПрибыли = 5;
    Сумма = Сумма + итератор.ПроцентПрибыли;
КонецЦикла;
КонецПроцедуры
   LittlePumpkin
 
3 - 17.08.20 - 20:24
Код совсем небольшой, какого черта запускается повторный обход я не понимаю(
   RomanYS
 
4 - 17.08.20 - 20:47
(0) Начни с начала: создал расширение, захватил процедуру...
Включи отладчик и по стеку вызовов определи почему (исходная) процедура вызывается дважды.
   ReaLg
 
5 - 17.08.20 - 21:12
(0) Вангую: не 2 раза цикл пробегается при вызове процедуры, а процедура 2 раза дергается...
   ReaLg
 
6 - 17.08.20 - 21:15
(4) Не дочитал :))
   hhhh
 
7 - 17.08.20 - 22:45
(3) может Процедура Расш1_ПриОткрытииПосле к двум событиям привязана
   zelyak
 
8 - 18.08.20 - 06:20
Версия сохранена ?
   LittlePumpkin
 
9 - 18.08.20 - 07:26
Процедура действительно дергается два раза:
1)В ПодключаемыеКомандыКлиент.НачатьОбновлениеКоманд(ЭтотОбъект);
2) Непосредственно обрабатывает сама "После".
Охренеть весело. И как это заблокировать? Поставить условие перед циклом?
   Галахад
 
10 - 18.08.20 - 08:12
(9) Ну, вроде как сейчас в "ПриОткрытии" ничего с данными не делают. Используют "ПриСозданииНаСервере".
   uno-group
 
11 - 18.08.20 - 08:49
Сумма=0 может нужно все таки перед циклом прописать.
   rudnitskij
 
12 - 18.08.20 - 15:15
(2) то есть процедура при каждом открытии добавляет 5 * ЧислоСтрок к сумме документа? При каждом открытии?
Интересно, что хотел заказчик...
   rudnitskij
 
13 - 18.08.20 - 15:16
(11) перезапись данных документа при каждом открытии - что может быть прекраснее))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.