Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Обход данных формы

Обход данных формы
Я
   LittlePumpkin
 
17.08.20 - 18:37
Хочу обойти объект ДанныеФормыКоллекция. Написал такой код:

итератор = 0;
Для каждого итератор из Объект.Товары Цикл
значение = Объект.Товары[итератор].Сумма;    
итератор = итератор + 1;
КонецЦикла;

Выпадает ошибка "Получение элемента по индексу для значения не определено". Подскажите в чем проблема и как обойти ДанныеФормыКоллекция?
   Ненавижу 1С
 
1 - 17.08.20 - 18:39
Для каждого...
   LittlePumpkin
 
2 - 17.08.20 - 18:42
Понял ошибку, изменил на Счетчик = 0 по 5 Цикл
Но если я заранее не знаю сколько будет итераций? Какое выражение поставить вместо 5?
   Ёпрст
 
3 - 17.08.20 - 18:48
(2)
Для каждого итератор из Объект.Товары Цикл
    значение = итератор.Сумма;    
КонецЦикла;
   LittlePumpkin
 
4 - 17.08.20 - 18:55
Спасибо вам огромное! Спрошу здесь же, чтобы не создавать новой темы: как теперь полученную переменную значение вывести в отдельную колонку на форме для каждого элемента из Объект.Товары? (3)
   LittlePumpkin
 
5 - 17.08.20 - 19:01
Когда пытаюсь присвоить вот так
Элементы.Сумма = значение;
говорит что "Поле объекта недоступно для записи"
   youalex
 
6 - 17.08.20 - 19:03
(4)  В отдельную колонку или в отдельное поле?
   Ненавижу 1С
 
7 - 17.08.20 - 19:05
Огласите всю задачу
   LittlePumpkin
 
8 - 17.08.20 - 19:06
Отдельная колонка. Товары - это табличная часть и я пытаюсь добавить колонку где будет отображаться переменная "значение" (6)
   LittlePumpkin
 
9 - 17.08.20 - 19:07
(7) Хочу взять колонку из Объект.Товары (Товары это тч), пересчитать ее и вывести в новую колонку на форме.
   Ненавижу 1С
 
10 - 17.08.20 - 19:11
//просто пример


Для каждого Стр из Объект.Товары Цикл
    Стр.Сумма = Стр.Количество*Стр.Цена;    
КонецЦикла;
   LittlePumpkin
 
11 - 17.08.20 - 19:16
(10) Блин совсем мозги под конец дня не варят. Спасибо большое!
   LittlePumpkin
 
12 - 17.08.20 - 20:08
Снова проблема( Цикл почему то обходится два раза: доходит до конца процедуры и снова запускает цикл. В чем проблема?
   youalex
 
13 - 17.08.20 - 20:24
Откуда ты его вызываешь? Из обработчика события?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.