Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Получить значения поля

Получить значения поля
Я
   denis_z3x
 
17.08.20 - 14:16
Здравствуйте!
Кто знает, как получить список значений дополнительного реквизита.
Есть дополнительный реквизит с выпадающим списком.
Есть имя реквизита "ДополнительныйРеквизитЗначение_....." Получаю его на сервере через такую функцию

&НаСервере
Функция ПолучитьПолеДополнительногоРеквизитаНаФорме(Форма, ИмяРеквизита) Экспорт
    
    Список = Форма.Свойства_ОписаниеДополнительныхРеквизитов;
    
    Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Имя", ИмяРеквизита);
    
    Если ЗначениеЗаполнено(Свойство) Тогда
        НайденныеСтроки = Список.НайтиСтроки(Новый Структура("Свойство", Свойство));
        Если НайденныеСтроки.Количество() > 0 Тогда
            Возврат НайденныеСтроки[0];        
        КонецЕсли;        
    КонецЕсли;
    
КонецФункции

Как можно получить список значений?
   youalex
 
1 - 17.08.20 - 14:58
УправлениеСвойствами.ПолучитьСписокЗначенийСвойств(Свойство)
   denis_z3x
 
2 - 17.08.20 - 15:20
(1) Огромное Спасибо.
А не подскажите как мне сделать выбор на форме нужного мне значений.

Что я хочу:
1. Получаю список значений (УправлениеСвойствами.ПолучитьСписокЗначенийСвойств(Свойство))
2. Перебираю его и "Выбираю" нужное мне значение и подставляю его в поле.
   youalex
 
3 - 17.08.20 - 15:41
в смысле неинтерактивно сделать выбор? Если у тебя есть имя соответствующего реквизита, так и пиши ЭтотОбъект.ДополнительныйРеквизитЗначение_.. = ВыбранноеЗначение. Не очень понял что нужно
   youalex
 
4 - 17.08.20 - 15:42
А, ну то есть если имя реквизита динамически определяется, тогда
ЭтотОбъект[ИмяРеквизита] = ВыбранноеЗначение
   denis_z3x
 
5 - 17.08.20 - 16:00
(3) (4)  Выручил! Спасибо!
А то я особо не программист 1С. 3 дня голову ломаю ...)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.