Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не сохраняется цвет в хранилище значений

Не сохраняется цвет в хранилище значений
Я
   Nzzzz
 
17.08.20 - 09:16
Доброго времени суток!)
Не получается сохранить цвет в хранилище значений.
РеквизитЦвет - реквизит объекта с типом хранилище значений.
РеквизитФормыЦвет - реквизит формы с типом Цвет.
В итоге получаю: 0,0,0
Подскажите, что делаю не так?
КОД:

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    ТекущийОбъект = РеквизитФормыВЗначение("Объект");
    РеквизитФормыЦвет = ТекущийОбъект.РеквизитЦвет.Получить();
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект,ПараметрыЗаписи)
    ТекущийОбъект.РеквизитЦвет = Новый ХранилищеЗначения(РеквизитФормыЦвет);
КонецПроцедуры
   ДенисЧ
 
1 - 17.08.20 - 09:26
А в цвете видать, цвет из стиля?
   ДенисЧ
 
2 - 17.08.20 - 09:27
   Nzzzz
 
3 - 17.08.20 - 09:40
(1) нет, абсолютный
   Nzzzz
 
4 - 17.08.20 - 09:41
(2) у меня как там, но не работает
   ДНН
 
5 - 17.08.20 - 09:50
Добавь вот это:

ТекущийОбъект = РеквизитФормыВЗначение("Объект");
РеквизитФормыЦвет = ТекущийОбъект.РеквизитЦвет.Получить();

в ПриЧтенииНаСервере
   Nzzzz
 
6 - 17.08.20 - 09:56
(5) Сейчас попробую
   Nzzzz
 
7 - 17.08.20 - 10:00
Всё равно всё по нулям(((
    
       Свойство                       Значение              Тип
ЭтотОбъект.РеквизитФормыЦвет           0,0,0                Цвет
   Вид                               Абсолютный            ВидЦвета
   Зеленый                                   0              Число
   Красный                                   0              Число 
   синий                                     0              Число
   Nzzzz
 
8 - 17.08.20 - 10:28
В общем у меня было через Диалог
(Диалог = Новый ДиалогВыбораЦвета; 
    Если Диалог.Выбрать() Тогда 
        ВыбранныйЦвет = Диалог.Цвет;
    КонецЕсли;
поэтому не получалось. Теперь просто реквизит на форме с типом цвет, из него выбираю
   Nzzzz
 
9 - 17.08.20 - 10:30
теперь другая проблема
   Nzzzz
 
10 - 17.08.20 - 10:32
Мне этот цвет нужно взять, но совершенно в другом объекте.
Я вот этот реквизитЦвет, пишу так: яойОбъект.РеквизитЦвет.Получить();
Возвращает неопределено
   Nzzzz
 
11 - 17.08.20 - 10:41
Всё хорошо, всё работает!
   acht
 
12 - 17.08.20 - 10:58
(10) > яойОбъект

Вооот..

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.