Вход | Регистрация
 

Нет значения согласовано в Заявке на расходование денежных средств

Нет значения согласовано в Заявке на расходование денежных средств
Я
   TolstiyBeremenniy
 
13.08.20 - 12:54
Документ Заявка на расходование денежных средств, поле статус , есть значения не согласовано и отклонена.

Почему нет согласовано ?
   TolstiyBeremenniy
 
1 - 13.08.20 - 12:58
   РБ
 
2 - 13.08.20 - 13:03
Права
   TolstiyBeremenniy
 
3 - 13.08.20 - 13:05
(2) УТ 11.2, не подскажете какую роль добавить?
   РБ
 
4 - 13.08.20 - 13:07
(3) помочь залезть в Конфигуратор?
   1Сергей
 
5 - 13.08.20 - 13:07
(1) а у записанной?
   TolstiyBeremenniy
 
6 - 13.08.20 - 13:07
(4) я залез, толь что именно делать не известно же пока, узнаю
   TolstiyBeremenniy
 
7 - 13.08.20 - 13:12
Похоже эта процедура, но что за право, пока не пойму.

&НаСервере
Процедура УстановитьСписокСтатусов()
    
    СписокВыбора = Элементы.Статус.СписокВыбора;
    
    Если Не ПравоСогласования ИЛИ Не ПравоУтверждения Тогда
        
        СписокВыбора.Очистить();
        СписокВыбора.Добавить(Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.НеСогласована);
        СписокВыбора.Добавить(Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.Отклонена);
        
        Если ПравоСогласования
         ИЛИ Объект.Статус = Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.Согласована Тогда
            СписокВыбора.Добавить(Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.Согласована);
        КонецЕсли;
        
        Если ПравоУтверждения
         ИЛИ Объект.Статус = Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.КОплате Тогда
            СписокВыбора.Добавить(Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.КОплате);
        КонецЕсли;
        
    КонецЕсли;
    
КонецПроцедуры
   TolstiyBeremenniy
 
8 - 13.08.20 - 13:13
ПравоСогласования = Ложь
ПравоУтверждения  = Ложь

А как сделать истина? Что именно установить в правах, какую роль?
   РБ
 
9 - 13.08.20 - 13:15
ПравоСогласования = ПраваПользователяПовтИсп.СогласованиеЗаявокНаРасходованиеДенежныхСредств();
    ПравоУтверждения  = ПраваПользователяПовтИсп.УтверждениеЗаявокНаРасходованиеДенежныхСредств();
   TolstiyBeremenniy
 
10 - 13.08.20 - 13:16
(9) Да спасибо, нашел

Функция СогласованиеЗаявокНаРасходованиеДенежныхСредств(Пользователь = Неопределено) Экспорт
    Возврат Пользователи.РолиДоступны("СогласованиеЗаявокНаРасходованиеДенежныхСредств", Пользователь, Ложь);
КонецФункции
   РБ
 
11 - 13.08.20 - 13:17
(10) и "Утверждение к оплате" еще есть ;)
   TolstiyBeremenniy
 
12 - 13.08.20 - 13:18
(11) На появление согласованно (10) вроде внияет
   TolstiyBeremenniy
 
13 - 13.08.20 - 13:20
(11) Спасибо, учту. Тоже добавляю тогда!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.