Вход | Регистрация
 

Как из цикла сохранить число чтобы потом сложить его с другим из этого же цикла? УТ10.3

Как из цикла сохранить число чтобы потом сложить его с другим из этого же цикла? УТ10.3
Я
   Shecurok
 
13.08.20 - 12:37
Всем привет.
Есть такой цикл который выводит данные в табличную часть:

Для Каждого ттс из ИНН_ Цикл
                    Если ттс.Сумма1 = 0 и ттс.Сумма2 = 0 Тогда
                        Стр_Осн = Остатки.НайтиСтроки(Новый Структура("Контрагент, ИНН, Сумма1, Сумма2",ттс.Контрагент, ттс.ИНН, ттс.Сумма1, ттс.Сумма2));
                        Для Каждого стр из Стр_Осн Цикл
                            стр.ВыводитьСтроку = Ложь;
                        КонецЦикла;
                        Продолжить;
                    КонецЕсли;
                    Секция2.Параметры.Контрагент = ттс.Контрагент;
                    Секция2.Параметры.Сумма1     = ттс.Сумма1;
                    СуммаВРублях                 = тс.Сумма2;
                    Если тс.ДоговорКонтрагентаВалютаВзаиморасчетов.Код = "978" Тогда
                        СуммаВРублях  = ттс.Сумма1 * КурсЕвро.Курс;
                    Иначе
                        Секция.Параметры.Сумма1  = 0;
                        СуммаВРублях             = тс.Сумма1;
                    КонецЕсли;
                    Секция2.Параметры.Сумма2  = СуммаВРублях;

Сначала в цикле в Сумма2 получается одно число, потом другое. Мне их необходимо сложить.
Никак не могу додуматься как это реализовать. Просто сейчас все это дело выводится в секции два, а мне надо результат сложения записать будет в секцию1. Но это же другие проблемы, сейчас надо решить эту.
   Kesim
 
1 - 13.08.20 - 12:40
(0) сумма3 = 0 , до цикла , и сумма3 = сумма3 + сумма2 в цикле
   Shecurok
 
2 - 13.08.20 - 12:41
(1) спасибо, попробю
   Kesim
 
3 - 13.08.20 - 12:51
(2) ничего личного, но надеюсь вы не программист)))
   Shecurok
 
4 - 13.08.20 - 12:55
(3) не программист) больше все таки по учету)
   Shecurok
 
5 - 13.08.20 - 12:58
(3) не подскажите, а почем в этом коде Преобразование к Числ не может быть выполнено? (сумма3)
Для Каждого ттс из ИНН_ Цикл
                    Если ттс.Сумма1 = 0 и ттс.Сумма2 = 0 Тогда 
                        Стр_Осн = Остатки.НайтиСтроки(Новый Структура("Контрагент, ИНН, Сумма1, Сумма2",ттс.Контрагент, ттс.ИНН, ттс.Сумма1, ттс.Сумма2));
                        Для Каждого стр из Стр_Осн Цикл
                            стр.ВыводитьСтроку = Ложь;
                        КонецЦикла;
                        Продолжить; 
                    КонецЕсли;
                    Секция2.Параметры.Контрагент = ттс.Контрагент;
                    Секция2.Параметры.Сумма1     = ттс.Сумма1;
                    СуммаВРублях                 = тс.Сумма2;
                    Если тс.ДоговорКонтрагентаВалютаВзаиморасчетов.Код = "978" Тогда 
                        СуммаВРублях  = ттс.Сумма1 * КурсЕвро.Курс;
                    Иначе
                        Секция.Параметры.Сумма1  = 0;
                        СуммаВРублях             = тс.Сумма1;
                    КонецЕсли;
                    Секция2.Параметры.Сумма2  = СуммаВРублях;
                    сумма3 = сумма3 + СуммаВРублях;
                    //ТабличныйДокумент.Вывести(Секция2);

                    Стр_Осн = Остатки.НайтиСтроки(Новый Структура("Контрагент, ИНН, Сумма1, Сумма2",ттс.Контрагент, ттс.ИНН, ттс.Сумма1, ттс.Сумма2));
                    Для Каждого стр из Стр_Осн Цикл
                        стр.ВыводитьСтроку = Ложь;
                    КонецЦикла;
                КонецЦикла;
   Shecurok
 
6 - 13.08.20 - 13:00
забыл перенести Смма3 = 0, может из за этого, сейчас посомтрю
   Shecurok
 
7 - 13.08.20 - 13:02
да, из-за этого, все полчилось, спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.