Вход | Регистрация
 

Временное хранилище хранилище значений

Временное хранилище хранилище значений
Я
   Pyryrym
 
10.08.20 - 13:13
У меня есть таблица, в которой в столбце изображение указаны адреса картинок вида "C:\123", а в столбце адрес изображения отображаются сами картинки.
Со следующим кодом это работает

&НаКлиенте
Процедура ЗагрузитьКартинки(Строка)
    
    Оповещение = Новый ОписаниеОповещения("ЗагрузитьКартинкиЗавершить", ЭтотОбъект, Строка);
    НачатьПомещениеФайла(Оповещение,,Строка.Изображение, Ложь, УникальныйИдентификатор);
    
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьКартинкиЗавершить(Результат, Адрес, ВыбранноеИмяФайла, Строка)Экспорт
    
    Для Каждого Стр Из Объект.Таблица Цикл
        Если Стр.Артикул = Строка.Артикул Тогда
            Стр.АдресИзображения = Адрес;
        КонецЕсли;
    КонецЦикла;
    
КонецПроцедуры

Однако, при попытке добавить картинку в номенклатуру, обращаясь к АдресуИзображения следующим путем:

ЭлементСправочника.ФайлХранилище = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Строка.АдресИзображения));

ничего не происходит. По моей задумке, АдресИзображения - адрес временного хранилища, однако отладчик говорит, что его значение "", но при этом на форме отображается картинка. Как и к чему стоит обращаться, чтобы получить данные картинки и загрузить их в справочник?

Список тем форума
Рекламное место пустует  Рекламное место пустует
Глупец, лишенный способности посмеяться над собой вместе с другими, не сможет долго выносить программирование.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.