Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

как получить последнюю строку в соответствии?

как получить последнюю строку в соответствии?
Я
   Ybr
 
10.08.20 - 10:33
Для каждого стр1 из Соответствие  цикл

ПослСтрока = ?
   Asmody
 
1 - 10.08.20 - 10:38
В Соответствии порядок записей не определен
   Ботаник Гарден Меран
 
2 - 10.08.20 - 10:38
Я тут в партнерке как-то читал признание бывшего начальника про то, как он на порядок строк в соответствии заложился.
   Ybr
 
3 - 10.08.20 - 10:40
(1) метод количество() дает  точное количество строк выводимых в цикле
   Ybr
 
4 - 10.08.20 - 10:40
(1) мне вот надо последнюю строку )
   azernot
 
5 - 10.08.20 - 10:41
МоёСоответствие.Получить(МоёСоответствие.Количество()-1)

Но если в (1) - правда, то это будет хрень.
   Ybr
 
6 - 10.08.20 - 10:42
(5) щаз проверю)
   Ybr
 
7 - 10.08.20 - 10:47
(5) а что он получит ? индекс  . мне нужно значение
   Asmody
 
8 - 10.08.20 - 10:49
(3) Ещё раз перечитай (1)
   Ybr
 
9 - 10.08.20 - 10:54
(8) перечитал  1
   Ybr
 
10 - 10.08.20 - 10:56
как то можно получить послед строку в соответствии?
   pavig
 
11 - 10.08.20 - 10:56
(0)
На это нельзя опираться.
Но если таки очень надо, то просто пробежать циклом и забрать последнее.
   SleepyHead
 
12 - 10.08.20 - 10:57
(0) как ты упорядочиваешь значения соответствия ?
   palsergeich
 
13 - 10.08.20 - 10:58
(10) Соответствие это неупроядоченная коллекция.
Понятия первый и последний в том виде как это есть в ТЗ - там нет
   palsergeich
 
14 - 10.08.20 - 10:59
то что последнее сейчас, после добавления еще одной строки может продолжать оставаться последним, а так же внезапно может стать первым.
   Ybr
 
15 - 10.08.20 - 10:59
(13) это я понял . но если из данных 4 строки всегда то ведь можно как то 4 получить
   Ybr
 
16 - 10.08.20 - 11:00
(11) вот и я про то пишу . как мне посл поулчить
   Ybr
 
17 - 10.08.20 - 11:01
получаю  данные с сайта всегда 4  значения в колонке
   palsergeich
 
18 - 10.08.20 - 11:01
Для каждого КлючЗначение из Соответствие Цикл
 Ключ = КлючЗначение.Ключ;
 Значение = КлючЗначение.Значение;
КонецЦикла
   Ybr
 
19 - 10.08.20 - 11:03
(18) щас посмотрим
   Ybr
 
20 - 10.08.20 - 11:07
Для каждого КлючЗначение из ОКВЭД Цикл
 Ключ = ОКВЭД.Получить(ОКВЭД.Количество()-1);
  Значение = КлючЗначение.Значение;
  
  Сообщить(Значение);


выводит все
   SleepyHead
 
21 - 10.08.20 - 11:11
(20) Очевидно, что все они последние.
   ДенисЧ
 
22 - 10.08.20 - 11:12
Для каждого КлючЗначение из ОКВЭД Цикл
 Ключ = КлючЗначение.Ключ
  Значение = КлючЗначение.Значение;
КонецЦикла;  
  Сообщить(Значение);
   Ybr
 
23 - 10.08.20 - 11:24
(22) да норм сделал проверил получилось спасиб
   Быдло замкадное
 
24 - 10.08.20 - 11:44
(0) при записи в соответствие всегда обновляй "Соответствие.ПоследнееДобавленноеЗначение"
   ДенисЧ
 
25 - 10.08.20 - 11:49
(24) Да он из жисона читает... Так что руками туда не добавляется...
   ДенисЧ
 
26 - 10.08.20 - 11:49
Точнее - не руками
   Megas
 
27 - 10.08.20 - 11:51
(23) Я бы подумал что это и для чего тебе это, тебе уже написали несколько раз что в Соответствии нет последнего и первого значения. Они все равны.

Значения там получаются по КЛЮЧУ, ключ - уникальный.

Можно конечно придумать что то типа: отсортироваться по ключу по возрастанию и получить последнее значение.
   Ybr
 
28 - 10.08.20 - 12:30
(27) сомневаюсь в написанном  вами

все значения разные .   последние значение получаю .
вот так 
Для каждого КлючЗначение из ОКВЭД Цикл
 Ключ = КлючЗначение.Ключ
  Значение = КлючЗначение.Значение;
КонецЦикла;  
  Сообщить(Значение); 

все работает .
   Ybr
 
29 - 10.08.20 - 12:31
вот в отчете код не заработал . вот теперь буде думать почему )
   Ybr
 
30 - 10.08.20 - 12:32
в обработке работает в отчете нет
 
 Рекламное место пустует
   lEvGl
 
31 - 10.08.20 - 12:39
Соответствие (Map)
Элементы коллекции:

КлючИЗначение
Для объекта доступен обход коллекции посредством оператора Для каждого … Из … Цикл. При обходе выбираются элементы соответствия.
Возможно обращение к значению элемента посредством оператора [...]. В качестве аргумента передается значение ключа элемента.

Методы:

Вставить (Insert)
Количество (Count)
Очистить (Clear)
Получить (Get)
Удалить (Delete)


предполагаю, что Соответствие[Соответствие.Количество() - 1] должно работать, но с проверкой ЗначениеЗаполнено(Соответствие) например
   lEvGl
 
32 - 10.08.20 - 12:40
семен семеныч...
   acht
 
33 - 10.08.20 - 12:47
(26) А ты ТСу точно пожелал, что я тебя просил? =)
   Ybr
 
34 - 10.08.20 - 12:50
(32) ))
   Ybr
 
35 - 10.08.20 - 12:51
(33) ты в игноре  у меня с вчерашнего дня в черном списке.
   acht
 
36 - 10.08.20 - 12:53
(35) Гм. А зачем тогда отвечаешь? Или это из серии "Три дня я гналась за вами, чтобы сказать, как вы мне безразличны"?
   Ybr
 
37 - 10.08.20 - 12:54
(36) отвечаю .чтобы ты понял .
   Ybr
 
38 - 10.08.20 - 12:58
в отчете ( не скд )
 у метода получить не объектный тип . 
значение не является значением объектного типа .

полагаю  дело в получении значения в цикле   хз
   Ybr
 
39 - 10.08.20 - 13:04
прощайте братья ушел на обед
   Ybr
 
40 - 10.08.20 - 13:05
(36) а ты муж или жен? что то я не понял
   Megas
 
41 - 10.08.20 - 13:30
(31)
[...]. В качестве аргумента передается значение ключа элемента.

НЕ думаю что так  "Соответствие[Соответствие.Количество() - 1]" будет работать,  всё же это индекс, а не "ключ элемента"
   ssh2006
 
42 - 10.08.20 - 13:39
(31) работает только по ключу


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.