Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Параметры в процедурах и Функциях

Параметры в процедурах и Функциях
Я
   Юлианна_Н
 
07.08.20 - 15:39
Огромная просьба помочь разобраться....скажем так, в теории понимаю, но в практике не могу использовать.

Есть некая задача: сделать что то похожее на структуру подчиненных документов.
Цепочка формируется, все ок.
В регистр запись происходит, в той форме как и планироала.

Теперь, по кнопке (по нажатию) откроется форма подчиненного или родительского документа - все круто, мне нрав. Но...
Кнопки называются "КП" и "Заказ" а я хочу, что бы Заголовок был = Наименование документа( подчиненного или родительского,  соответсвтенно).
Результат у меня, получился, Но мне пришлось дважды делать похожый запрос в разных процедурах:
1. при нажатии - Запрос на получение документа из регистра.
2. приОткрытии(что бы получить Строка(Документ.Заказ), к примеру).

Итого два одинаковых запроса. И тут появилась мысль ... а как бы мне получить Возврат = (к команде свой) и Возврат = (ПриОткрытии) свой?
Так то не принципиально.... но мне каж что так было бы посимпатиШнее.
   DTX 4th
 
1 - 07.08.20 - 15:42
Эм? Поместить это в экспортную функцию и вызывать ее, а не две разных?
   Юлианна_Н
 
2 - 07.08.20 - 16:07
... А Экспортную то можно хранить где угодно?!!! Правильно я помню...
   lamme
 
3 - 07.08.20 - 16:20
(2)
нет. не везде.
   Юлианна_Н
 
4 - 07.08.20 - 16:23
ну в модуле формы, к примеру, просто она будет вызываться только тут
   lamme
 
5 - 07.08.20 - 16:24
так можно
   Юлианна_Н
 
6 - 07.08.20 - 16:26
а обращаться к ней так же как и к остальным?

ЭкспортнаяПроцедура();   ???
   lamme
 
7 - 07.08.20 - 16:28
Функция МоЯФункция(СтруктураВходящихПараметров)
Возврат  СтруктураВходящихПараметров.ПараметрА+СтруктураВходящихПараметров.ПараметрБ
конецфункции

Процедура НажатиеКнопки()

для каждого СтрокаТовара из Товары цикл

СтрПрм = новый Структура();
СтрПрм.Вставить("ПараметрА", 10)
СтрПрм.Вставить(ПараметрБ"", 12)
СтрокаТовара.СуммаЗначений = МоЯФункция(СтрПрмв);
конеццикла;
конефпроцедуры
   Юлианна_Н
 
8 - 07.08.20 - 16:31
Отчасти понятно... потом разберусь лучше. Вот только не понятно, как писать (сюда) разноцветным? Или скрины вставлять?
В общем как у тебя/Вас получилось код сюда вставить в таком виде?
   lamme
 
9 - 07.08.20 - 16:32
оно само
   lamme
 
10 - 07.08.20 - 16:32
тут оно само разноцветничивается
   Юлианна_Н
 
11 - 07.08.20 - 16:33
Процедура КупитьШоколадкуЗаПомощь()

Сообщить("Огромное спасибо за подсказки!");

КонецПроцедуры
   Юлианна_Н
 
12 - 07.08.20 - 16:34
Как то не очень... :(
   lamme
 
13 - 07.08.20 - 16:36
это к Волшебнику
он магичит с цветами.
   fisher
 
14 - 07.08.20 - 16:40
Тест раскраски
Функция А()
   Возврат "А";
КонецФункции

   Юлианна_Н
 
15 - 07.08.20 - 16:41
... а тут форумы не только по 1с?
Смотрю и политика тут же и квартирные вопросы...
   fisher
 
16 - 07.08.20 - 16:42
Да, с раскраской не очень.
А блоки кода определяются либо автоматически (часто - криво), либо можно их выделять тэгом 1С (в квадратных скобках и завершающий тэг со стандартным слэшем).
(15) Когда-то был по 1с. Сейчас вырождается в то, что видишь.
   lamme
 
17 - 07.08.20 - 16:42
при создании темы - выбирай блок - куда создается новая тема.
а то придет модератор и забанят
   Юлианна_Н
 
18 - 07.08.20 - 16:43
Вроде правильно вибираю :(

Пускай простит, заранее
   Юлианна_Н
 
19 - 07.08.20 - 16:44
Ладно, я на сегодня КонецПроцедуры     :)
   lamme
 
20 - 07.08.20 - 16:44
а вообще . тут есть темы специальные для сра*ча
(смотри темы за 100-200 сообщений)
---

и тут принято - что тебя об*срут- пару раз поиздеваюстся
сделают умный вид - что все все знают-  но никто ничего не скажет.

это тут нормально
поэтому смотри по инету по другим форумам
   lamme
 
21 - 07.08.20 - 16:47
а если у  тебя слишком хитрый вопрос, что его никто не понял и не дал ответа
то используют

ап
   Юлианна_Н
 
22 - 07.08.20 - 16:49
(20) (21) окей, спасибо за наставничество...


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.