Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как сделать что бы рег. задание не запускалось при изменении реквизита "Использовать"?

Как сделать что бы рег. задание не запускалось при изменении реквизита "Использовать"?
Я
   Druzh0k
 
04.08.20 - 17:29
Есть список регл. заданий в Базе1, которые обновляют конфигурацию в других базах. По умолчанию реквизит "Использовать" у них выключен и у каждого из них есть свое расписание (например выполняться в 01.00.00; 02.00.00 ... 21.00.00, 22.00.00).
В рабочее время запускается другое регл.задание, которое проверяет появилось ли обновление конфигурации для базы: например конфигурация в хранилище конфигурации отличается от конфигурации базы. В таком случае у нужного регл.задания изменяется галка "Использовать" и если это время уже прошло, то регламентное задание автообновления сразу запускается. Как можно отменить запуск при изменении реквизита?
   asady
 
1 - 04.08.20 - 18:36
(0) покажи код которым меняете галку "использовать"
   Druzh0k
 
2 - 04.08.20 - 18:42
РегЗадание=РегламентныеЗадания.НайтиПоУникальномуИдентификатору(РегламентноеЗаданиеGUID);
Если РегЗадание<>Неопределено Тогда
    РегЗадание.Использование=Истина;
        РегЗадание.Записать();
КонецЕсли;

Для устранения своей проблемі сейчас сделала так, но пока не проверила:
РегЗадание=РегламентныеЗадания.НайтиПоУникальномуИдентификатору(РегламентноеЗаданиеGUID);
Если РегЗадание<>Неопределено Тогда
     РегЗадание.Использование=Истина;
     Если РегЗадание.Расписание.ТребуетсяВыполнение() Тогда
        РегЗадание.Расписание.ДатаНачала=КонецДня(ТекущаяДата())+2;
     КонецЕсли;
     РегЗадание.Записать();
КонецЕсли;
   Druzh0k
 
3 - 04.08.20 - 18:57
(3) проверила, работает. Но не знаю, когда вылезет боком(

Если есть другие варианты, буду рада узнать.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.