Вход | Регистрация
 

Разница обычной формы с управляемой формой

Разница обычной формы с управляемой формой
Я
   AidkaMaidka
 
31.07.20 - 20:23
Здравствуйте. Пишу код в модуле объекта: на печатную форму в управляемой форме. Раньше в обычной форме у меня был вот такой код:

        Если не  ЗначениеЗаполнено(Ссылка.Д.ДатаСФ) Тогда
        ДП = "''___''________________200__г";
    Иначе
        ДП = Формат(Ссылка.ДатаСФ, "ДФ=dd.MM.yyyy");
    КонецЕсли;

А управляемой форме выдает ошибку: что Ссылка не определено. Попробовала вместе Ссылки поставить Объект но все равно выдает что Объект не определено.
   AidkaMaidka
 
1 - 31.07.20 - 20:24
(0) Ой извините код такой:
        Если не  ЗначениеЗаполнено(Ссылка.ДатаСФ) Тогда
        ДП = "''___''________________200__г";
    Иначе 
        ДП = Формат(Ссылка.ДатаСФ, "ДФ=dd.MM.yyyy");
    КонецЕсли;
   vde69
 
2 - 31.07.20 - 20:43
На клиенте нельзя получать данные из базы, это можно делать только на сервере
   vde69
 
3 - 31.07.20 - 20:45
(2) +это касается форм

А я не заметил, что у тебя модуль оьекта
   runoff_runoff
 
4 - 31.07.20 - 22:14
(0) а как сделано в типовых?
   AlvlSpb
 
5 - 31.07.20 - 22:56
(0) Какая Ссылка, если ты в модуле объекта?
Если не  ЗначениеЗаполнено(ДатаСФ) Тогда
        ДП = "''___''________________200__г";
    Иначе 
        ДП = Формат(ДатаСФ, "ДФ=dd.MM.yyyy");
    КонецЕсли;
   vcv
 
6 - 31.07.20 - 22:58
ДокументОбъект.<Имя документа> (DocumentObject.<Document name>)
ЭтотОбъект (ThisObject)
Использование:
Только чтение.
Описание:
Тип: ДокументОбъект.<Имя документа>.
Содержит сам объект базы данных. Предназначено, в основном, для получения данного объекта встроенного языка в модуле объекта или модуле формы.
Доступность:
Сервер, толстый клиент, внешнее соединение, мобильное приложение (сервер).
Использование в версии:
Доступен, начиная с версии 8.0.
   vcv
 
7 - 31.07.20 - 22:59
Скописпастил синтакс-помошник по ЭтотОбъект, а там почему-то даже слово такого не упоминается :(
Надо писать Если не  ЗначениеЗаполнено(ЭтотОбъект.ДатаСФ) Тогда
   hhhh
 
8 - 31.07.20 - 23:07
(5) есть там Ссылка, ты не поверишь
   hhhh
 
9 - 31.07.20 - 23:09
(7) ЭтотОбъект можно не писать. просто ДатаСФ
   AlvlSpb
 
10 - 31.07.20 - 23:29
(8) А что ты меня в неверующие записал? Здесь "какая" в смысле "зачем".
   AlvlSpb
 
11 - 31.07.20 - 23:46
(0) Есть подозрение, что твой код не в модуле объекта, а в модуле менеджера (раз уж речь о печати)
   AidkaMaidka
 
12 - 01.08.20 - 05:28
(11) Да, кстати в модуле менеджера,спасибо
   AidkaMaidka
 
13 - 01.08.20 - 09:36
(6) Пробовала, не помогает
   AidkaMaidka
 
14 - 01.08.20 - 09:36
(9) Тоже выдает ошибку
   Бишбармак
 
15 - 01.08.20 - 10:10
Тогда придется скопировать сюда всю процедуру.
   AlvlSpb
 
16 - 01.08.20 - 10:19
В модуле менеджера, в процедуру печати передается массив объектов для печати.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.