Вход | Регистрация
 

Как получить СКД списка справочника со всеми полями?

Как получить СКД списка справочника со всеми полями?
Я
   DTX 4th
 
31.07.20 - 11:11
Как получить СКД списка справочника со всеми полями?
   Uzyf
 
1 - 31.07.20 - 11:53
в смысле СКД?
   DTX 4th
 
2 - 31.07.20 - 11:55
(1) Схему СКД.
С запросом вида "Выбрать * ИЗ Справочник.ХимическиеЭлементы"
   Uzyf
 
3 - 31.07.20 - 12:05
(2) может ты имеешь в виду запрос динамического списка справочника, из формы списка? или я нихера не понял
   JeHer
 
4 - 31.07.20 - 12:10
Пятница, день админа, надо доставать пиво и чипсы.
   DTX 4th
 
5 - 31.07.20 - 12:25
(3) Получить схему из динамического списка легко, но у меня на форме нет списка.

Вот что хочу:
1. Выбираю справочник
2. В компоновщик настроек подсовываю схему СКД этого справочника
3. У меня появляется возможность делать отборы по его реквизитам
   RomanYS
 
6 - 31.07.20 - 12:27
(5) >> схему СКД этого справочника
Такой сущности нет. Можно запрос "выбрать *.." в построитель загнать.
Что с отборами планируется делать?
   ГдеСобакаЗарыта
 
7 - 31.07.20 - 12:30
Обработка Групповое изменение реквизитов
   DTX 4th
 
8 - 31.07.20 - 12:33
(6) Просто отобрать по нему для начала
Попробую через построитель, спасибо
   RomanYS
 
9 - 31.07.20 - 12:36
(8) Я не знаю, есть ли у него(построителя) нормальный интерфейс в УФ. Полностью опиши что надо.
ВыгрузкаЗагрузкаXML82 по ощущениям на построителе должна быть, но там ОФ
   DTX 4th
 
10 - 31.07.20 - 12:39
(9) Отобрать ссылки с отбором, который укажет пользователь. На УФ.
Видимо, придется обработки поковырять. Думал, можно быстренько получить схему СКД справочника.
   Uzyf
 
11 - 31.07.20 - 12:42
(10) "Отобрать ссылки с отбором" - отобрать куда?
   RomanYS
 
12 - 31.07.20 - 12:46
(10) Вот из универсального отчёта в КА2 (на СКД)
Функция СхемаКомпоновкиДанных(ФиксированныеПараметры) Экспорт 
    СхемаКомпоновкиДанных = ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
    СхемаКомпоновкиДанных.ПоляИтога.Очистить();
    
    ИсточникДанных = СхемаКомпоновкиДанных.ИсточникиДанных.Добавить();
    ИсточникДанных.Имя = "ИсточникДанных1";
    ИсточникДанных.ТипИсточникаДанных = "Local";
    
    НаборДанных = СхемаКомпоновкиДанных.НаборыДанных.Добавить(Тип("НаборДанныхЗапросСхемыКомпоновкиДанных"));
    НаборДанных.Имя = "НаборДанных1";
    НаборДанных.ИсточникДанных = ИсточникДанных.Имя;
    НаборДанных.Запрос = ТекстЗапросаПоМетаданным(ФиксированныеПараметры);
    НаборДанных.АвтоЗаполнениеДоступныхПолей = Истина;
    
    ДобавитьИтоги(ФиксированныеПараметры, СхемаКомпоновкиДанных);
    
    Если ФиксированныеПараметры.ТипОбъектаМетаданных = "Справочники"
        Или ФиксированныеПараметры.ТипОбъектаМетаданных = "ПланыВидовРасчета" 
        Или (ФиксированныеПараметры.ТипОбъектаМетаданных = "РегистрыСведений"
            И Метаданные[ФиксированныеПараметры.ТипОбъектаМетаданных][ФиксированныеПараметры.ИмяОбъектаМетаданных].ПериодичностьРегистраСведений 
            = Метаданные.СвойстваОбъектов.ПериодичностьРегистраСведений.Непериодический) Тогда
        СхемаКомпоновкиДанных.Параметры.Период.ОграничениеИспользования = Истина;
    КонецЕсли;
    
    ДоступныеТаблицы = ДоступныеТаблицы(ФиксированныеПараметры.ТипОбъектаМетаданных, ФиксированныеПараметры.ИмяОбъектаМетаданных);
    Если ДоступныеТаблицы.Количество() < 2 Тогда
        СхемаКомпоновкиДанных.Параметры.ИмяТаблицы.ОграничениеИспользования = Истина;
    КонецЕсли;
    
    Возврат СхемаКомпоновкиДанных;
КонецФункции

Список тем форума
Рекламное место пустует  Рекламное место пустует
AdBlock убивает бесплатный контент. 1Сергей
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.