Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Как правильно записать значение в доп. реквизит справочника?

Как правильно записать значение в доп. реквизит справочника?
Я
   Поросян
 
25.07.20 - 18:28
В данном случае конфигурация "Розница 2.2".
Мне нужно програмно установить значение доп. реквизита.

Если захожу в свойства этого реквизита, то вот такой рисунок.

И там в разделе "для разработчика" указано, его название   "Коллекция_a139f5f7c5d140119b1823355bc0bc63"
https://i.imgur.com/0ORPxHk.png

Как бы правильнее записать туда значение для справочника "номенклатура"?

Понимаю конечно, что через планы видов характеристик это надо делать. Но более, чем уверен, что есть в БСП универсальная функция для этого.
   Ненавижу 1С
 
1 - 25.07.20 - 18:34
Функция ПолучитьСвойство(Имя)

    Возврат ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоРеквизиту("Имя", Имя);        

КонецФункции 

Процедура УстановитьЗначениеДополнительногоРеквизитаОбъекта(Объект, ИмяРеквизита, Значение) Экспорт 

    Свойство = ПолучитьСвойство(ИмяРеквизита);    
    Строки = Объект.ДополнительныеРеквизиты.НайтиСтроки(Новый Структура("Свойство",Свойство));
    Если Строки.Количество()>0 Тогда
        Строки[0].Значение = Значение;
        Возврат;    
    КонецЕсли; 
    
    ДоступныеСвойства = УправлениеСвойствами.СвойстваОбъекта(Объект,Истина,Ложь);    
    Если ДоступныеСвойства.Найти(Свойство)=Неопределено Тогда
        ВызватьИсключение "Нет реквизита "+ИмяРеквизита;
    КонецЕсли;     
    Строка = Объект.ДополнительныеРеквизиты.Добавить();
    Строка.Свойство = Свойство;
    Строка.Значение = Значение;
    
КонецПроцедуры
   Поросян
 
2 - 25.07.20 - 18:40
(1)спасибо друг!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.