Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

УФ ОбработкаВыбора при СтандартнаяОбработка = ЛОЖЬ

УФ ОбработкаВыбора при СтандартнаяОбработка = ЛОЖЬ
Я
   Юзер123
 
24.07.20 - 10:23
Доброго времени.

Есть обработка в ней 2 реквизита

1 - номер проекта
2  - Документ некий..  

При выборе документа с условием что номер проекта не заполнен все работает  стандартно, но если номер проекта заполняется то надо доки показывать по отбору.

&НаКлиенте
Процедура ВыборДокументаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
    // Вставить содержимое обработчика.
    Если не ВыборПроекта.Количество() = 0 тогда
    СтандартнаяОбработка = ЛОЖЬ;
    ЗначениеОтбора = Новый Структура();
    Для Каждого СтрокаПроект из ВыборПроекта Цикл
    ЗначениеОтбора.Вставить("НомерПроектаДоговора", СтрокаПроект.Значение);
    КонецЦикла;
    ПараметрыВыбора = Новый Структура("Отбор", ЗначениеОтбора);
    
    
    ОткрытьФорму("Документ.МойДокумент.ФормаВыбора", ПараметрыВыбора);
    КонецЕсли;

КонецПроцедуры


Но в обработку выбора не заходит.  Подскажите в чем дело пож-та
   Василий Алибабаевич
 
1 - 24.07.20 - 10:28
(0) Ставлю на то, что здесь : "ВыборПроекта.Количество()" написана какая-то фигня. Что на это говорит тов. отладчик?
   Юзер123
 
2 - 24.07.20 - 10:29
(1) Там все ок.  Мне кажется дело не в этом.   Документы отбираются по проекту как надо в форме выбора, но после выбора не  передается в реквизиты формы.
   Ёпрст
 
3 - 24.07.20 - 10:29
(0) в ОткрытьФорму не верное указание формы
   Юзер123
 
4 - 24.07.20 - 10:31
(3) Форма выбора же
   acht
 
5 - 24.07.20 - 10:32
(2) >  Документы отбираются по проекту как надо в форме выбора
Неа. У тебя всегда отбор по последнему проекту.

Ну и при открытии формы надо указывать владельца, у которого должна отработать обработка выбора.
   Юзер123
 
6 - 24.07.20 - 10:33
(5) Как надо?)
   Kesim
 
7 - 24.07.20 - 10:34
(0) если отладчик не останавливается возможно процедура в свойствах поля не проставлена?
   Юзер123
 
8 - 24.07.20 - 10:34
(7)  Проставлена
   Юзер123
 
9 - 24.07.20 - 10:34
ОткрытьФорму("Документ.МойДокумент.ФормаВыбора", ПараметрыВыбора,Элемент); (5)
   Юзер123
 
10 - 24.07.20 - 10:35
А как в отбор список подсунуть?
   acht
 
11 - 24.07.20 - 10:37
(10) В СП в описании параметра все написано.
   Юзер123
 
12 - 24.07.20 - 10:37
(9) (5)  да и даже так в обработчик ОбработкаВыбора не попадает
   Юзер123
 
13 - 24.07.20 - 10:38
(12) о.. все ок.
   Юзер123
 
14 - 24.07.20 - 10:38
А как список то подсунуть?))) последний вопрос
   Ёпрст
 
15 - 24.07.20 - 10:47
   Юзер123
 
16 - 24.07.20 - 10:51
   Юзер123
 
17 - 24.07.20 - 10:52
Спс

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.