Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Замена типовой печатной формы ЗУП 3

Замена типовой печатной формы ЗУП 3
Я
   iva77ru
 
20.07.20 - 16:58
Зарплата и управление персоналом, редакция 3.1 (3.1.10.470)

Добрый день.

Нужно выполнить подмену типовой печатной формы. Пробывал через описание внешней обработки не получилось. В подменю печать отображается типовая и внещняя печатная форма. Пример ниже


Функция СведенияОВнешнейОбработке() Экспорт
  
    ПараметрыРегистрации = Новый Структура;
    ПараметрыРегистрации.Вставить("Вид", "ПечатнаяФорма"); //Варианты: "ДополнительнаяОбработка", "ДополнительныйОтчет", "ЗаполнениеОбъекта", "Отчет", "ПечатнаяФорма", "СозданиеСвязанныхОбъектов"
    
    МассивНазначений = Новый Массив();
    МассивНазначений.Добавить("Документ.СправкаНДФЛ");// например: "Документ._ДемоСчетНаОплатуПокупателю"
    //МассивНазначений.Добавить("Документ.<ИмяДокумента2>");
    ПараметрыРегистрации.Вставить("Назначение", МассивНазначений);
    
    ПараметрыРегистрации.Вставить("Наименование", "Справка о доходах (2-НДФЛ) - замена типовой");
    ПараметрыРегистрации.Вставить("Версия", "1.0"); //например: "1.0"
    ПараметрыРегистрации.Вставить("БезопасныйРежим", ЛОЖЬ); //Варианты: Истина, Ложь
    ПараметрыРегистрации.Вставить("Информация", "Печатная форма 2-НДФЛ для сотрудников (Подпись, печать)");
    ПараметрыРегистрации.Вставить("ВерсияБСП", "2.2.1.4");// не ниже какой версии БСП подерживается обработка
    
    ТаблицаКоманд = ПолучитьТаблицуКоманд();
    
    ДобавитьКоманду(ТаблицаКоманд,
    НСтр("ru = 'Справка о доходах (2-НДФЛ) - Новая'"),//для отображения пользователю
    "Форма2НДФЛ_Должность",    //можно использовать для подмены поставляемой печатной формы
    "ВызовСерверногоМетода",  //Использование.  Варианты: "ОткрытиеФормы", "ВызовКлиентскогоМетода", "ВызовСерверногоМетода"  
    Ложь,//Показывать оповещение. Варианты Истина, Ложь
    "ПечатьMXL",//Модификатор
    "Форма2НДФЛ"); //Строка с идентификаторами заменяемых внутренних печатных форм. Например "Счет,Заказ"
    
    
    ПараметрыРегистрации.Вставить("Команды", ТаблицаКоманд);
    
    Возврат ПараметрыРегистрации;

КонецФункции

Функция ПолучитьТаблицуКоманд()

  Команды = Новый ТаблицаЗначений;
  Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ПоказыватьОповещение", Новый ОписаниеТипов("Булево"));
  Команды.Колонки.Добавить("Модификатор", Новый ОписаниеТипов("Строка"));
  Команды.Колонки.Добавить("ЗаменяемыеКоманды", Новый ОписаниеТипов("Строка"));
  
  Возврат Команды;

КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование, ПоказыватьОповещение = Ложь, Модификатор = "",ЗаменяемыеКоманды = "")

  НоваяКоманда = ТаблицаКоманд.Добавить();
  НоваяКоманда.Представление = Представление;
  НоваяКоманда.Идентификатор = Идентификатор;
  НоваяКоманда.Использование = Использование;
  НоваяКоманда.ПоказыватьОповещение = ПоказыватьОповещение;
  НоваяКоманда.Модификатор = Модификатор;
  НоваяКоманда.ЗаменяемыеКоманды = ЗаменяемыеКоманды;

КонецПроцедуры
   Momus
 
1 - 20.07.20 - 19:38
Нет такого в бсп
   Akela has missed
 
2 - 20.07.20 - 21:35
ЗаменяемыеКоманды. Все есть. Главное правильно указать имя.
   iva77ru
 
3 - 21.07.20 - 08:20
Все правильно указал. Открыл менеджер объекта док-та СправкаНДФЛ. Идентификатор = "Форма2НДФЛ". тоже указал в "ЗаменяемыеКоманды".

// Заполняет список команд печати.

// 
// Параметры:

//   КомандыПечати - ТаблицаЗначений - состав полей см. в функции УправлениеПечатью.СоздатьКоллекциюКомандПечати.
//

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
    
    // Справка о доходах (2-НДФЛ)

    КомандаПечати = КомандыПечати.Добавить();
    КомандаПечати.Обработчик = "УправлениеПечатьюБЗККлиент.ВыполнитьКомандуПечати";
    КомандаПечати.Идентификатор = "Форма2НДФЛ";
    КомандаПечати.Представление = НСтр("ru = 'Справка о доходах (2-НДФЛ)'");
    КомандаПечати.ПроверкаПроведенияПередПечатью = Ложь;

КонецПроцедуры
   Креатив
 
4 - 21.07.20 - 08:22
(0)А смысл?
   iva77ru
 
5 - 21.07.20 - 08:34
Смысл смылся, вот пытаюсь найти.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.