Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

КА вывод нескольких печатных форм вместо 1 из внешней печатной формы , выводит последнюю

КА вывод нескольких печатных форм вместо 1 из внешней печатной формы , выводит последнюю
Я
   olo_lo1
 
20.07.20 - 12:11
Подскажите, пытаюсь в доп печ форме счета вывести несколько счетов

Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "_СчетБезПодписи") Тогда
Для Каждого СсылкаНаОбъект Из МассивОбъектов Цикл
Для Каждого Стр Из ТЗ Цикл
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "_СчетБезПодписи", "Счет", СчетБезПодписи(Стр));
КонецЦикла;
КонецЦикла;
КонецЕсли;

Но он все равно выводит на экран только посл печатную форму. Что ей не нравится ?
   Сияющий Асинхраль
 
1 - 20.07.20 - 12:23
В типовом механизме печати все сложно. Когда понадобилось сделать печатных форм с количеством зависящим от контрагента, пришлось нужное количество раз программно копировать уже выведенную форму, а для этого надо менять код или пытаться захватить это через расширение. Но в любом случае, перед тем как все заработало потратил дня три изучая как же работает механизм печати в БСП...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.