Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Изменение свойств через код

Изменение свойств через код
Я
   Tony_More
 
20.07.20 - 11:55
Здравствуйте.

Проблема вот какая.
Необходимо когда условие неверное отключать возможность редактирования одной ячейки в табличной части документа. В свойствах нахожу Редактирование текста. Как мне отключить редактирование текста через код?
   qwerty42russ
 
1 - 20.07.20 - 11:56
Доступность = Ложь
   Tatitutu
 
2 - 20.07.20 - 11:57
ТвояКолонка.ТолькоПросмотр=Истина;
   Tony_More
 
3 - 20.07.20 - 11:59
Процедура ЗамечанияЗамечанияПриИзменении(Элемент)
    СтрокаТабличнойЧастиЗамечания = Элементы.Замечания.ТекущиеДанные.Замечания;
    
    Если СтрокаТабличнойЧастиЗамечания Тогда
        Элементы.Замечания.ТекущиеДанные.Комментарий = "";
    иначе
        Элементы.Замечания.ТекущиеДанные.Комментарий = "Комментарий не нужен";     
    КонецЕсли;
КонецПроцедуры

вот процедура
   Tony_More
 
4 - 20.07.20 - 11:59
Где иначе необходимо еще и запрещать ввод
   Галахад
 
5 - 20.07.20 - 12:12
Можно анализировать событие "Выбор", и посылать лесом.
   Tatitutu
 
6 - 20.07.20 - 12:32
&НаКлиенте
Процедура ЗамечанияПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
    Элемент.ПодчиненныеЭлементы.ЗамечанияКомментарий.ТолькоПросмотр = Элемент.ТекущиеДанные.Замечания; 
КонецПроцедуры
   Tony_More
 
7 - 21.07.20 - 10:50
Спасибо Tatitutu, сработало.

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.