Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Проверка заполнения реквизитов

Проверка заполнения реквизитов
Я
   Pyryrym
 
19.07.20 - 14:28
У меня есть форма, на которой находятся два реквизита - Сумма и Период, которые необходимо проверить перед выполнением основных действий - вот код

&НаКлиенте
Процедура ОтправитьПисьмо(Команда)
    
    Если ПроверкаЗаполнения() Тогда
        ОтправитьПисьмоНаСервере();
    КонецЕсли
    
КонецПроцедуры


Функция ПроверкаЗаполнения ()
    
    Если (Не Сумма > 99999) И (ЗначениеЗаполнено(Период)) Тогда
        Сообщение1 = Новый СообщениеПользователю;
        Сообщение1.Текст = "Неправильно заполнено";
        Сообщение1.Поле = Сумма;
        Сообщение1.Сообщить();
        Сообщение2 = Новый СообщениеПользователю;
        Сообщение2.Текст = "Неправилно заполнено";
        Сообщение2.Поле = Период;
        Сообщение2.Сообщить();
        Возврат Ложь;
    ИначеЕсли Не Сумма > 99999 Тогда
        Сообщение1 = Новый СообщениеПользователю;
        Сообщение1.Текст = "Неправильно заполнено";
        Сообщение1.Поле = Сумма;
        Сообщение1.Сообщить();
        Возврат Ложь;
    ИначеЕсли ЗначениеЗаполнено(Период) Тогда
        Сообщение2 = Новый СообщениеПользователю;
        Сообщение2.Текст = "Неправилно заполнено";
        Сообщение2.Поле = Период;
        Сообщение2.Сообщить();
        Возврат Ложь;
    Иначе Возврат Истина;    
    КонецЕсли;    
                
КонецФункции


Выдает ошибку - "Несоответствие типов".
   Amra
 
1 - 19.07.20 - 14:48
Все должны догадаться на какой строчке ругается? И это, продам отладчик, ДОРОГО
   Pyryrym
 
2 - 19.07.20 - 15:32
(1) во время отладки, при попытке выполнить обработку пишет - несоответствие типов, причем в отдельном окне, без указания строки, в конфигураторе ошибок не видит
   osa1C
 
3 - 19.07.20 - 15:51
Если ПроверкаЗаполнения() = Истина Тогда
   Pyryrym
 
4 - 19.07.20 - 19:10
Не работает(.
Я ещё по разному попробовал - та же ошибка.
А есть какой то пример сделанной проверки на заполнение реквизитов формы?
   Ненавижу 1С
 
5 - 19.07.20 - 19:27
Если Период это стандартный период, то наверное ЗначениеЗаполнено с ним не взлетит
   Momus
 
6 - 19.07.20 - 19:29
(0) у поля в СообщениеПользователю же тип строка, не?
   hhhh
 
7 - 19.07.20 - 19:33
(4)

       Сообщение2.Поле = Период; 

вот здесь хрень какая-то. Поле должно быть тип строка, а не дата.
   Momus
 
8 - 19.07.20 - 19:34
(7) да там везде в ПроверкаЗаполнения () тип не строка

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.