Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отладка HTTP запроса

Отладка HTTP запроса
Я
   seraf
 
17.07.20 - 12:44
Привет, почему не останавливается в конфигураторе? Рекомендации выполнил

Для локальной отладки можно указать tcp://localhost

Включение автоматического подключения
Для того чтобы платформа автоматически подключалась для отладки к вызываемым HTTP-сервисам нужно:

Открыть окно настроек автоматического подключения с помощью команды главного меню "Отладка – Автоматическое подключение".
Установить флажок "HTTP-сервисы на сервере".
Помните, что флажок следует устанавливать при каждом запуске конфигуратора, в котором требуется отладка HTTP-сервисов.

Переопубликовал, но на точке в процедуре выполнения не стопает
   Sysanin_1ц
 
1 - 17.07.20 - 12:55
Нужно в настройках указать что отладка по протоколу http и сделать публикацию базы с этими настройками. Если ведётся отладка серверного варианта то ещё указать параметр debug в реестре виндос
   seraf
 
2 - 17.07.20 - 13:03
не понял, вместо Разрешена (протокол TCP/IP) - Разрешена (протокол HTTP), адрес сервера localhost (у меня всё локально)
   seraf
 
3 - 17.07.20 - 13:04
попробовал не работает, вроде ж делаю как в ИТС написано
   seraf
 
4 - 17.07.20 - 13:06
там правда скрин какой-то старый, галка Разрешить отладку и адрес отладчика, у меня уже выбор между tcp b http
   palsergeich
 
5 - 17.07.20 - 13:08
(1) HTTP успешно отлаживаются и по tcp
   seraf
 
6 - 17.07.20 - 13:15
так почему не останавливается
   seraf
 
7 - 17.07.20 - 13:15
в настройках отладки tcp://DESKTOP-7QBD869:1560, порты 1560-1591
   palsergeich
 
8 - 17.07.20 - 13:18
(7) Кеш чистил?
   seraf
 
9 - 17.07.20 - 13:19
в другом браузере пробовал.. ща.
   seraf
 
10 - 17.07.20 - 13:27
хм, а запускаю Веб-клиент начать отладку, выдает окно localhost информационная база была опубликована без возможности отладки
хотя я публиковал с разрешить отладку по tcp как в (0)
   seraf
 
11 - 17.07.20 - 13:32
короче поставил вместо того что в ИТС написано tcp://localhost свой адрес отладчика tcp://DESKTOP-7QBD869:1560 и заработало
   kumena
 
12 - 17.07.20 - 13:59
> короче поставил вместо того что в ИТС написано tcp://localhost свой адрес отладчика tcp://DESKTOP-7QBD869:1560 и заработало

значит у вас в hosts соответствие не прописано
   seraf
 
13 - 17.07.20 - 14:54
(12) а что там прописать чтоб я знал

Список тем форума
Рекламное место пустует  Рекламное место пустует
Требовать и эффективности, и гибкости от одной и той же программы — все равно, что искать очаровательную и скромную жену... по-видимому, нам следует остановиться на чем-то одном из двух.
Фредерик Брукс-младший
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.