Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

После обновления БП3 не печатаются ВПФ с факсимилье

После обновления БП3 не печатаются ВПФ с факсимилье
Я
   Taugor
 
16.07.20 - 10:17
Всем привет!
После последнего обновления БП3, при печати внешних печатных форм, где есть факсимилье вываливается ошибка:
Неверный второй параметр Реквизиты в функции ОбщегоНазначения.ЗначенияРеквизитовОбъекта:
- Поле объекта "ФайлПодписьРуководителя" не найдено

Подскажите, как исправить проблему.
   shuhard
 
1 - 16.07.20 - 10:20
(0) оригинальные косяки исправляют локализуя в отладчике
   Taugor
 
2 - 16.07.20 - 10:24
(1) косяк я так понял массовый, реквизит "ФайлПодписьРуководителя" в спр Организации убрали.
думая, как обойти эту ситуацию, по вариантов нет.
   del123
 
3 - 16.07.20 - 10:40
Там подписи теперь у физлиц хранятся.
   Taugor
 
4 - 16.07.20 - 10:52
можно пример, как обратиться к элементу спр физлица за подписью?
   del123
 
5 - 16.07.20 - 11:20
Типовая функция, непосредственно из модуля заполнения факсимиле в печатных формах
// Возвращает двоичные данные картинки присоединенного файла факсимиле к физическому лицу

//
// Параметры:

//  ФизическоеЛицо - Ссылка на физическое лицо, к которой присоединена картинка
Функция ДвоичныеДанныеФаксимилеФизическогоЛица(ФизическоеЛицо) Экспорт
    
    ДвоичныеДанныеКартинки = Неопределено;
    
    Если ЗначениеЗаполнено(ФизическоеЛицо) Тогда
        
        ПрисоединенныйФайл = ПрисоединенныйФайлФаксимилеФизическогоЛица(ФизическоеЛицо);
        Если ЗначениеЗаполнено(ПрисоединенныйФайл) Тогда
            ДанныеКартинки = РаботаСФайлами.ДанныеФайла(ПрисоединенныйФайл);
            ДвоичныеДанныеКартинки = ПолучитьИзВременногоХранилища(ДанныеКартинки.СсылкаНаДвоичныеДанныеФайла);
        КонецЕсли;
        
    КонецЕсли;
    
    Возврат ДвоичныеДанныеКартинки;
    
КонецФункции
   del123
 
6 - 16.07.20 - 11:20
Функция ПрисоединенныйФайлФаксимилеФизическогоЛица(ФизическоеЛицо) Экспорт
    
    ПрисоединенныйФайл = Справочники.Файлы.ПустаяСсылка();
    
    Если ЗначениеЗаполнено(ФизическоеЛицо) Тогда
        ПрисоединенныйФайл = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(ФизическоеЛицо, "ФаксимилеПодписи");
    КонецЕсли;
    
    Возврат ПрисоединенныйФайл;
    
КонецФункции
   del123
 
7 - 16.07.20 - 11:20
Модуль управлениеПечатьюБП
   Taugor
 
8 - 16.07.20 - 13:19
(7) Большое спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.