Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

КД. ПКО для перечислени, которые есть в источнике, но нет в приемнике, как?

КД. ПКО для перечислени, которые есть в источнике, но нет в приемнике, как?
Я
   palpetrovich
 
13.07.20 - 19:26
При таком коде в ПКО, передВыгрузкой
Если Источник.ВидДоговора = Перечисления.ТипыДоговоров.ДоговорПереводДолга тогда
    Приемник.ВидДоговора = "";
КонецЕсли;

получаю ошибку
Не найдено соответствие для значения Источника
    Источник  =  Договор перевод долга

100 пудов что-то не так делаю, что?
   Chameleon1980
 
1 - 13.07.20 - 19:27
тогда хначение=неопределенл;
   palpetrovich
 
2 - 13.07.20 - 19:27
+ (0) 8.3 -> 7.7
   palpetrovich
 
3 - 13.07.20 - 19:28
(1) значение - это для ПКС - там что-то вобще туго при (2)
   palpetrovich
 
4 - 13.07.20 - 19:37
может в ПКЗ определить  Источник  "ДоговорПереводДолга"  - Приемник "0"
   Aleksey
 
5 - 13.07.20 - 20:28
Это что за дичь?

В ПКС ПередВыгрузкой
Если Источник.ВидДоговора = Перечисления.ТипыДоговоров.ДоговорПереводДолга тогда
    Отказ=1//в этом случае данное свойство выгружаться не будет и оно останется при загрузки без изменения

КонецЕсли;

Или
если 
Значение=""//будет загружено пустое значение

КонецЕсли;
   palpetrovich
 
6 - 13.07.20 - 20:30
(5)мне не нужен отказ, мне нужно пучтое значение
и да, (4) - сработало
   Chameleon1980
 
7 - 13.07.20 - 20:49
бля тот же только с боку как тебе и говорил через пкс (пкз)

Список тем форума
Рекламное место пустует  Рекламное место пустует
Здесь можно обсудить любую тему при этом оставаясь на форуме для 1Сников, который нужен для работы. Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.