Вход | Регистрация
 
Информационные технологии :: Администрирование

Перестали работать задания на сервере SQL

Перестали работать задания на сервере SQL
Я
   Ц_У
 
08.07.20 - 11:45
В один прекрасный момент полетели задания, ни одно не работает.
Как всегда ничего никто не трогал :)

Message
Executed as user: <...>. The step did not generate any output.  The return value was unknown.  The process exit code was -1073741515.  The step failed.

В чем причина и как попытаться починить?
Если это важно:
Microsoft SQL Server Management Studio                        12.0.2000.8
Microsoft Analysis Services Client Tools                        12.0.2000.8
Microsoft Data Access Components (MDAC)                        6.3.9600.16384
Microsoft MSXML                        3.0 6.0
Microsoft Internet Explorer                        9.11.9600.17031
Microsoft .NET Framework                        4.0.30319.34014
Operating System                        6.3.9600
   Ц_У
 
1 - 08.07.20 - 11:56
Если верить МСДН, то код -1073741515 - dll missing, попытка установить C++ Redistutable Package (как-то так) ни к чему ни привела
   acht
 
2 - 08.07.20 - 11:56
-1073741515 это C0000135, а это ЕМНИП "unable to locate component"

Что-то оно не находит =) А вот почему - вопрос. Не тот путь, изменились переменные окружения, нет прав и оно не видит файл...

Посмотри лучше на stackowerflow
   sitex
 
3 - 08.07.20 - 12:25
(0) Обновления в последние дни ставились windows ?
   tsaboy
 
4 - 08.07.20 - 12:31
вариант решения, запустить заново ручками, посмотреть лог, переназначить задания и проверить задания.
   Ц_У
 
5 - 08.07.20 - 13:07
(3) полностью отключены
   Ц_У
 
6 - 08.07.20 - 13:07
(4) Лог только это отображает, как настроить более подробно?
   ptiz
 
7 - 08.07.20 - 13:19
(0) Начать с перезагрузки ОС.
   Ц_У
 
8 - 08.07.20 - 13:21
(7) не помогло :)
пока один вариант - переехать на другой сервер и на нем все настроить, но воспаленный мозг желает знать почему.. .
   unregistered
 
9 - 08.07.20 - 13:21
А служба "Агент сервера SQL" точно запущена? Проверь в службах.
   Ёпрст
 
10 - 08.07.20 - 13:34
(0) агент работает хоть ?
   Ёпрст
 
11 - 08.07.20 - 13:34
о ёпт.. последнее сообщение не увидел
   sitex
 
12 - 08.07.20 - 13:38
(5) смотри логи винды, какие последние действия были. Так просто взять и не работать не может.
   Ц_У
 
13 - 08.07.20 - 13:38
(10) (9) Работают обе две, и скл и агент
   Ц_У
 
14 - 08.07.20 - 13:45
(12) Всплывающее окно приложения: DTExec.exe - Системная ошибка : Запуск программы невозможен, так как на компьютере отсутствует ATL100.DLL. Попробуйте переустановить программу.
   sitex
 
15 - 08.07.20 - 13:48
(14) А в системе присутствует ATL100.DLL ?  Поиск что дает ?
   sitex
 
16 - 08.07.20 - 13:49
(1) возможно какой то пакет  C ++ Redistributable  по херился . Посмотреть все какие установлены и переустановить их все
   Aleksey
 
17 - 08.07.20 - 13:57
   Ц_У
 
18 - 08.07.20 - 13:58
(15) два файла
C:\Windows\WinSxS\amd64_microsoft-windows-wid_31bf3856ad364e35_6.3.9600.16384_none_986967552fdc62b2\
C:\Windows\SysWOW64
   Ц_У
 
19 - 08.07.20 - 13:58
(17) ставили х64 сейчас х86 накатим
   Ц_У
 
20 - 08.07.20 - 15:12
Все накатили, ждем вечера, перезапустить
Продолжаю наблюдение
   Ц_У
 
21 - 09.07.20 - 08:33
Резюмирую:
переустановка С++ 2012 х86/х64 ничего не дала, длл в System32 не появился.
Сейчас взяли длл с соседнего сервака и запихали - все работает.
Открытым остается вопрос: Куда делась длл? Но это уже другая история
Всем спасибо за участие.


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.