Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Не получается открыть форму проводок.

Не получается открыть форму проводок.
Я
   РусскийВедун
 
07.07.20 - 22:11
К документу СчетНаОплатуПокупателю добавил проведения документа по регистру бухгалтерии.
На форме списка поставил кнопку ДтКт.
Процедура ДействияФормыРезультатпроведениядокумента(Кнопка)
    
    Если ЭлементыФормы.ДокументСписок.ТекущиеДанные = Неопределено тогда
        Возврат
    КонецЕсли;

    ОбщегоНазначения.РучнаяКорректировкаОсновнаяФорма(Ложь,ЭлементыФормы.ДокументСписок.ТекущиеДанные.Ссылка, ЭлементыФормы.ДокументСписок.ТекущиеДанные.Ссылка.ПолучитьОбъект());

КонецПроцедуры

Процедура РучнаяКорректировкаОсновнаяФорма(ЭтоНовый,Ссылка,ЭтотОбъект)  Экспорт
    
    Если НЕ ЭтоНовый Тогда
        ФормаНастройки = Обработки.КорректировкаДвижений.ПолучитьФорму("ОсновнаяФорма", , Строка(Ссылка));
        ФормаНастройки.ДокументОбъект = ЭтотОбъект;
        ФормаНастройки.Открыть();
    КонецЕсли;
    
КонецПроцедуры // РучнаяКорректировкаОсновнаяФорма()


При открытии обработки КорректировкаДвижений

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    Если ДокументОбъект = Неопределено Тогда
        Отказ = Истина;
    Иначе
        Если НЕ ОбщегоНазначения.ЕстьРеквизитДокумента("РучнаяКорректировка", ДокументОбъект.Метаданные()) Тогда
            РучнаяКорректировка = Ложь;
        Иначе
            РучнаяКорректировка = ДокументОбъект.РучнаяКорректировка;
        КонецЕсли;
        
        Если НЕ (ДокументОбъект.Проведен ИЛИ РучнаяКорректировка) Тогда
            Предупреждение("Документ не проведен. Для получения информации о результатах проведения документ необходимо провести.");
            Отказ = Истина;
        КонецЕсли;        
    КонецЕсли;
КонецПроцедуры

Тут почему-то ДокументОбъект = Неопределено. С другими документами все нормально. Что тут еще необходимо сделать?
   Ёпрст
 
1 - 07.07.20 - 22:17
(0) в составном типе добавьте свой новый мид документа для реквизита ДокументОбъект
   РусскийВедун
 
2 - 07.07.20 - 22:19
Составной тип это где?
   Ёпрст
 
3 - 07.07.20 - 22:24
(2) в форме   Обработки.КорректировкаДвижений.ПолучитьФорму("ОсновнаяФорма", 

есть реквизит ДокументОбъект, он составной (судя по коду) и у этого реквизита нет нужного вам вида документа
   РусскийВедун
 
4 - 07.07.20 - 22:28
спасибо

Список тем форума
Рекламное место пустует  Рекламное место пустует
Миста — веселый ресурс со своими эксклюзивными тараканами Ymryn
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.