Вход | Регистрация
 

Почему ОбходРезультатаЗапроса.ПоГруппировкам может не заходить в какую-либо группировку?

Почему ОбходРезультатаЗапроса.ПоГруппировкам может не заходить в какую-либо группировку?
Я
   evorle145
 
07.07.20 - 15:40
Рез = ПостроительОтчета.Результат.Выгрузить();
вот в этой строке отладчиком смотрю, все норм, все уровни группировки есть.
Но начинаю обход результата запроса и внутрь цикла "Пока ВыборкаВидРемонта.Следующий() Цикл" никогда не заходит:

ПостроительОтчета.Выполнить();
    РезультатЗапроса = ПостроительОтчета.Результат;
    
    ВыборкаТочкаПродаж = РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
    Пока ВыборкаТочкаПродаж.Следующий() Цикл
        // Вставить обработку выборки ВыборкаТочкаПродаж
    
        ВыборкаВидРемонта = ВыборкаТочкаПродаж.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
        Пока ВыборкаВидРемонта.Следующий() Цикл
            // Вставить обработку выборки ВыборкаВидРемонта
    
            ВыборкаНоменклатура = ВыборкаВидРемонта.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
    
            Пока ВыборкаНоменклатура.Следующий() Цикл
                // Вставить обработку выборки ВыборкаНоменклатура
            КонецЦикла;
        КонецЦикла;
    КонецЦикла;

Текст обхода сформирован автоматически конструктором запросов
   evorle145
 
1 - 07.07.20 - 15:51
Сейчас убрал ПостроительОтчета, сделал просто через запрос - все заработало как надо, группировки отработали....
Но мне-то нужен построитьОтчета, что с ним не так? почему он дает обойти группировки?
   fisher
 
2 - 07.07.20 - 16:26
ПостроительОтчета - это уже позабытое искусство из тьмы веков. Окаменелый предок СКД. Но зачем он тебе, если ты сам обходить собираешься? Используй ПостроительЗапроса.
   evorle145
 
3 - 07.07.20 - 18:25
(2) понял, спасибо. На построитель вышел открыл обработку печатьценников. А там все через него сделано. (Комплексная автоматизация ред1). Сейчас переключился на СКД. Все через СКД буду делать.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Закон Брукера: Даже маленькая практика стоит большой теории.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.