Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Подключение расширения работы с файлами web клиент. Не подключается из команды документа

Подключение расширения работы с файлами web клиент. Не подключается из команды документа
Я
   kobzon2
 
06.07.20 - 16:12
Всем привет. Нужен коллективный разум))
Никак не могу понять поведения платвормы. Платформа 8.3.15.1747.
Во внешней обработке кидаю команду на клиенте. В ней пишу код, что ниже. Запускаю в хроме, всё отрабатывает. РаширениеПодключено = Истина.
Беру документ, создаю команду на клиенте, пишу туда тот же код, запускаю в хроме, РасширениеПодключено = Ложь. На моменте попытки подключение ругается на модальность асинхронность. Не выходя из хрома запускаю обработку, код отрабатывает, снова запускаю команду документа, код так же отрабатывает нормально.
Как такое может быть? Всю голову уже сломал.

                #Если ВебКлиент Тогда
        
        // Попробуем подключить расширение работы с файлами
        РасширениеПодключено = ПодключитьРасширениеРаботыСФайлами();
        Если НЕ РасширениеПодключено Тогда
            // Расширение не установлено, пробуем установить
            УстановитьРасширениеРаботыСФайлами();
        КонецЕсли;
        
        РасширениеПодключено =  ПодключитьРасширениеРаботыСФайлами();
        Если Не РасширениеПодключено Тогда
            // Расширение не удалось установить, сообщаем об этом пользователю
            ПоказатьПредупреждение( , НСтр("ru = 'Для выполнения данной операции вам нужно установить расширение работы с файлами.'"));
            Возврат;
        КонецЕсли;
        
          #КонецЕсли
   kobzon2
 
1 - 06.07.20 - 16:48
Получается отрабатывает какая то процедура, которая подключает расширение, когда я открываю файл обработки.
   kobzon2
 
2 - 06.07.20 - 17:16
Всё понял. Надо было делать через НачатьПодключениеРасширенияРаботыСФайлами()

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.