Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Процедура проверки ключа защиты

Процедура проверки ключа защиты
Я
   flcy
 
05.07.20 - 17:11
Добрый день! Идея такая, хотелось бы сделать процедуру проверки ключа защиты.
Что то типо этого

&НаСервере
Процедура ДоступКОбработкеНаСервере()
    ////////проверка
    Если КлючКОбработке = Справочники.Ключи.НайтиПоРеквизиту("Ключ",,,) Тогда
        
    Иначе
        Возврат; ///закрыть процедуру
    КонецЕсли;    
    
КонецПроцедуры

&НаКлиенте
Процедура ДоступКОбработке(Команда)
    ДоступКОбработкеНаСервере();
КонецПроцедуры
   Ненавижу 1С
 
1 - 05.07.20 - 17:43
Зачем?
   flcy
 
2 - 05.07.20 - 18:23
(1) Что зачем?
   acht
 
3 - 05.07.20 - 18:28
(2) Делай-делай. Потом не будешь париться с этими ключами - можно будет копировать базу сразу вместе с ними. Жизнь всем облегчишь.
   МимохожийОднако
 
4 - 05.07.20 - 18:31
(0)Делай.
А зачем делаешь?
   MWWRuza
 
5 - 05.07.20 - 19:37
Не, ну можно конечно так и сделать, как первый этап проверки, что ключ вообще есть. Почему-бы и нет. А дальше, нужно легитимность самого ключа проверять - с привязкой к чему-то уникальному, как минимум ИНН(естественно в шифрованном виде), или еще к чему-то, это уж как фантазии хватит...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.