Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

БП 3 чек на отгрузку и оплату

БП 3 чек на отгрузку и оплату
Я
   isa2net
 
02.07.20 - 17:15
Приветствую!В БП 3.0.78.69 При одновременной отгрузке и оплате ставит "оплата кредитом" и платеж/выплата, хотя должен быть "товар" и "полный расчет".
И смотрю в коде:
// Оплата в разрезе номенклатуры счета
            Для каждого СтрокаСчета Из ОплачиваемыеПозицииСчета Цикл
                СтрокаПозицииЧека = МенеджерОборудованияКлиентСервер.ПараметрыФискальнойСтрокиЧека();
                
                Если НЕ ЭтоВерсия105 Тогда
                    ПризнакСпособаРасчета = Неопределено;
                ИначеЕсли СтрокаСчета.КоличествоОтгружено >= СтрокаСчета.Количество Тогда
                    // Если передача не сопровождается оплатой
                    Если ОплачиваемыйДокумент.СуммаОплаты = 0 Тогда
                        Если ОплачиваемыйДокумент.СуммаОплатыВсего = 0 Тогда
                            // Товар не был оплачен ранее.
                            ПризнакСпособаРасчета = Перечисления.ПризнакиСпособаРасчета.ПередачаБезОплаты;
                        ИначеЕсли ОстатокКОплате = 0 Тогда
                            // Товар был ранее оплачен полностью (нет остатка к оплате по ставке).
                            ПризнакСпособаРасчета = Перечисления.ПризнакиСпособаРасчета.ПередачаСПолнойОплатой;
                        Иначе
                            // Товар был оплачен ранее частично.
                            ПризнакСпособаРасчета = Перечисления.ПризнакиСпособаРасчета.ПередачаСЧастичнойОплатой;
                        КонецЕсли
                    Иначе
                        // Если передача сопровождается оплатой
                        ПризнакСпособаРасчета = Перечисления.ПризнакиСпособаРасчета.ОплатаКредита;
                    КонецЕсли;
                Иначе
                    ПризнакСпособаРасчета = ПризнакПредоплатыПоСчету;
                КонецЕсли;

Вот эта строка из какой логики при одновременной отгрузке и оплате, должен стоять "полный расчет": // Если передача сопровождается оплатой
                        ПризнакСпособаРасчета = Перечисления.ПризнакиСпособаРасчета.ОплатаКредита;?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.