Вход | Регистрация
 

Что сделать, чтобы отправленное из базы письмо сохранилось в "отправленных"?

Что сделать, чтобы отправленное из базы письмо сохранилось в "отправленных"?
Я
   Мисти
 
01.07.20 - 14:05
собчственно, вопрос.
Для 7, но думаю, разницы нет.
   ДенисЧ
 
1 - 01.07.20 - 14:34
Отправить его импом в нужную папку
   Мисти
 
2 - 01.07.20 - 15:45
(1) подробнее можно? Какре-нибудь ключевое слово? Думаю, там какая-то одна команда!
   ДенисЧ
 
3 - 01.07.20 - 15:46
ща. Базу запущу
   ДенисЧ
 
4 - 01.07.20 - 15:56
Во. Какашко-код, но работает...

                                    ящики = ИнтернетПочтаIMAP.ПолучитьПочтовыеЯщики();
                                    фл = Ложь;
                                    Для Каждого ящ из Ящики Цикл
                                        Если ВРег(ящ) = "ОТПРАВЛЕННЫЕ" ИЛИ ВРег(ящ) = "SENT" Тогда
                                            Попытка
                                                ИнтернетПочтаIMAP.ТекущийПочтовыйЯщик = ящ;
                                            Исключение
                                                ТекстОшибок = Символы.ПС + ТекстОшибок + (Строка(УчетнаяЗапись) + ". Ошибка помещения письма в 'Отправленные'
                                                |" + ОписаниеОшибки());
                                                
                                                #Если Клиент Тогда
                                                Если ПоказыватьОкноВыполнения Тогда
                                                    СтрокаТаблицыСостояния.Состояние = Перечисления.СостоянияСобытий.Отменено;
                                                КонецЕсли;
                                                #КонецЕсли
                                            
                                                Продолжить;
                                                
                                            КонецПопытки;
                                            фл = Истина;
                                            Прервать;
                                        КонецЕсли;
                                    КонецЦикла;
   Мисти
 
5 - 01.07.20 - 16:37
Спасибище!!!
   Мисти
 
6 - 01.07.20 - 16:47
Письмо = СоздатьОбъект("CDO.Message");

    
    Письмо.To    = Адрес;
    Письмо.From    = Отправитель;
    Письмо.Subject     = Тема;
    Письмо.TextBody = Текст;
    Письмо.TextBodyPart.Charset = "iso-8859-5";
    Письмо.AddAttachment(КаталогДляЗаписи);
    
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusing").Value                 = 2;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserver").Value             = SMTPСервер;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpauthenticate").Value         = 1;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendusername").Value             = Отправитель;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendpassword").Value             = Пароль;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpserverport").Value         = SMTPПорт;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpconnectiontimeout").Value    = 60;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/sendmailaddress").Value         = Адрес;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpusessl").Value             = ПротоколШифрования;
    Письмо.Configuration.Fields.Item("http://schemas.microsoft.com/cdo/configuration/smtpconnectiontimeout").Value = 60;

    Письмо.Configuration.Fields.Update();
    
    Попытка
        Письмо.Send();
        Форма.Отправка.Заголовок("");


у меня вот такое там, пока не пойму, к чему прикрутить. Или всё переделывать?
   Мисти
 
7 - 01.07.20 - 16:49
//Антон { сохранить письмо в Отправленных

Если ЗначениеЗаполнено(Профиль.АдресСервераIMAP) Тогда
    ИнтернетПочта = Новый ИнтернетПочта;
    ИнтернетПочта.Подключиться(Профиль, ПротоколИнтернетПочты.IMAP);
    ИнтернетПочта.ТекущийПочтовыйЯщик = "Отправленные";
    ИнтернетПочта.Послать(Письмо,, ПротоколИнтернетПочты.IMAP);
    ИнтернетПочта.Отключиться();
КонецЕсли;
//---}

еще вот такое нашла
   Мисти
 
8 - 01.07.20 - 16:55
СоздатьОбъект("ИнтернетПочта") - для 7 так, что ли ? Или не будет работать?
   ДенисЧ
 
9 - 01.07.20 - 17:06
(8) Нет в 8ке СоздатьОбъект()...
   Мисти
 
10 - 01.07.20 - 18:18
мне же для 7 надо. Говорят, там это все в dll зашито. Пока не нашла явно для 7.
   Мисти
 
11 - 01.07.20 - 18:24
Отправка почты CDO - вот там всё похоже, и тоже нет сохранения, кажется.

Список тем форума
Рекламное место пустует  Рекламное место пустует
Ошибка? Это не ошибка, это системная функция.
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.