Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Отладчик не попадает в форму документа в расширении

Отладчик не попадает в форму документа в расширении
Я
   lirt82
 
27.06.20 - 04:40
В расширении конфигурации (Бух 3.0, платформа 8.3.16.1148) добавил собственный объект документ создал для него форму списка и форму документа. В модуле формы списка есть процедура

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
    
КонецПроцедуры

отладчик в нее попадает. В модуле формы документа есть точно такая же процедура но отладчик ее "не видит". Как исправить?)
   lirt82
 
1 - 27.06.20 - 04:42
(0) в модуле формы документа сделал специально ошибку
&НаСервере
Процедура ОрганизацияПриИзмененииНаСервере()
    а = 1 / 0;
КонецПроцедуры

&НаКлиенте
Процедура ОрганизацияПриИзменении(Элемент)
    ОрганизацияПриИзмененииНаСервере();
КонецПроцедуры

тут отладчик попадает в процедуры
   rphosts
 
2 - 27.06.20 - 04:44
Отладка на стервере вкл?
   lirt82
 
3 - 27.06.20 - 04:46
(2) база файловая на локальном компе
   lirt82
 
4 - 27.06.20 - 04:54
   lirt82
 
5 - 27.06.20 - 05:06
(0) проблема решена, в свойствах формы документа в событии ПриСозданииНаСервере не была указана сама процедура:-)))0
   Chameleon1980
 
6 - 27.06.20 - 07:50
это не семерка 😀
   2mugik
 
7 - 27.06.20 - 17:54
Обычно тупо жму добавить в расширение и никаких проблем

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.