Вход | Регистрация
 

Не работает отладка серверных процедур

Не работает отладка серверных процедур
Я
   falselight
 
25.06.20 - 09:36
В реестре установил отладку Компьютер\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\1C:Enterprise 8.3 Server Agent (x86-64)

"C:\Program Files\1cv8\8.3.16.1148\bin\ragent.exe" -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "C:\Program Files\1cv8\srvinfo" -debug -http

Но почему то точка останова не срабатывает на серверной процедуре. Подскажите что я не так сделал ?????
   ccskn
 
1 - 25.06.20 - 09:40
(0) ...\CurentControlSet\...
   falselight
 
2 - 25.06.20 - 09:41
   falselight
 
3 - 25.06.20 - 09:42
(1) Что не так? Что нужно исправить?
   falselight
 
4 - 25.06.20 - 09:44
   Волшебник
 
Модератор
5 - 25.06.20 - 09:44
надо перезапустить сервер
надо отладчиком подключиться к серверному сеансу
   falselight
 
6 - 25.06.20 - 09:45
(5) Я это делал.
Сервер перезапустить службу? http://joxi.ru/Dr8De5vTzqjYJr
   Волшебник
 
Модератор
7 - 25.06.20 - 09:45
(6) обязательно
   ccskn
 
8 - 25.06.20 - 09:46
ну и коли уж через http установили отладку - в конфигураторе поменяли протокол и правильно сервера отладки указали?
   falselight
 
9 - 25.06.20 - 09:49
(8) Пока хочу добиться отладку серверных процедур. Точка останова в серверной процедуре не срабатывает (

http://joxi.ru/gmvaZ43tvj8b4r
   falselight
 
10 - 25.06.20 - 09:49
Не знаю что я ещё не перезапустил (
   ccskn
 
11 - 25.06.20 - 09:50
(9) Сервис - Параметры - Отладка - покажите что там
   falselight
 
12 - 25.06.20 - 09:53
Вроде как сейчас сработало !!!

http://joxi.ru/eAObaQlCp8QoV2
   falselight
 
13 - 25.06.20 - 09:53
   ccskn
 
14 - 25.06.20 - 09:55
(12) не забывайте про соответствие протоколов отладки ) обычно программа ругается, когда из конфигуратора режим отладки запускаете про несоответствие ...
   falselight
 
15 - 25.06.20 - 11:55
(14)

Это все нужно вот в этой строке изменять?

"C:\Program Files\1cv8\8.3.16.1148\bin\ragent.exe" -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "C:\Program Files\1cv8\srvinfo" -debug -http

А если нужна отладка TCP/IP, то убрать -http нужно?
   Demasiado
 
16 - 25.06.20 - 13:36
раньше -debug написанный в самом конце не работал, указывали в середине строки, вроде перед range
   falselight
 
17 - 25.06.20 - 15:28
(16) Я сегодня проверял у себя. Все работает.

Первый раз поставил SQL Server себе и развернул тестовую базу.

Создал объект для проверки, и 2 процедуры. Серверная и клиентская.

В начале, да не работало. Но я настроил. И я делал изначально по примеру с видео. То есть там, так изначально делали.

Настали, видимо новые времена !!!!

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.