Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

СКД, перезаполнение пользовательских настроек, при изменении.

СКД, перезаполнение пользовательских настроек, при изменении.
Я
   SkillUp
 
22.06.20 - 14:46
Есть отчет СКД (УФ), надо перезаполнять пользовательские настройки, при изменении какой-то из настройки Т.е. пример, в отчете есть, параметр "ДатаНач" и "ДатаКон", надо менять  (ДатаКон), если изменили "ДатНач" (допустим к "ДатаКон" = "ДатаНач" +Неделя). Перезаполнять настройки не проблема, не могу понять, как отловить изменение пользовательских настроек? В какой процедуре такое можно реализовать?

Попробовал эти обработчики:

&НаКлиенте
Процедура КомпоновщикНастроекПользовательскиеНастройкиВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
    Сообщить("Выбор");
КонецПроцедуры

&НаКлиенте
Процедура КомпоновщикНастроекПользовательскиеНастройкиПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
    Сообщить("При окончании редактирования");
КонецПроцедуры

&НаКлиенте
Процедура КомпоновщикНастроекПользовательскиеНастройкиВыборЗначения(Элемент, Значение, СтандартнаяОбработка)
    Сообщить("Выбор значения");

КонецПроцедуры

&НаКлиенте
Процедура КомпоновщикНастроекПользовательскиеНастройкиОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
    Сообщить("Обработка выбора");

КонецПроцедуры

Ни один не отработал... Как правильно?
   toypaul
 
1 - 22.06.20 - 14:47
ПриИзменении
   SkillUp
 
2 - 22.06.20 - 14:51
(1) Странно, но тоже сообщение не вывело...

&НаКлиенте
Процедура КомпоновщикНастроекПользовательскиеНастройкиПриИзменении(Элемент)
    Сообщить("При изменнии!");
КонецПроцедуры

Что-то не так делаю...
   SkillUp
 
3 - 22.06.20 - 14:53
(1) Ладно, ход мыслей понятен. Буду искать из-за чего не срабатывает. Спасибо за подсказку...

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.