Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Кнопка Печать в расширении, форма списка документа

Кнопка Печать в расширении, форма списка документа
Я
   lirt82
 
18.06.20 - 07:42
В конфе используется БСП версии 3.1.2, сделал как по мануалу https://its.1c.ru/db/bsp312doc#content:53:hdoc
в расширении создал свой документ с формами списка и формой документа, не получается в командной панели добавить команду печати. Снимки модулей ниже.
https://fex.net/ru/s/esvcvlp
что не так?)
   hhhh
 
1 - 18.06.20 - 08:22
(0) что-то не видно эту команду у вас на картинке. Где вы ее захватили в расширение?
   lirt82
 
2 - 18.06.20 - 08:57
(1) в расширении не передавал никаких команд
   чувак
 
3 - 18.06.20 - 14:14
(0) В окне редактирования документа есть закладка "Команды"?
   lirt82
 
4 - 18.06.20 - 14:26
(3) конечно есть:)
   lirt82
 
5 - 18.06.20 - 14:27
тама пусто) (3)
   FIXXXL
 
6 - 18.06.20 - 14:33
(0) к этому документу вообще есть команды Печати? Подменю с названием определенного формата ЕМНИП должно быть на форме
   lirt82
 
7 - 18.06.20 - 17:52
(6) нет, пусто
   lirt82
 
8 - 18.06.20 - 17:53
может тогда добавить команду на форму и отобразить на форме в виде кнопки?
   lirt82
 
9 - 18.06.20 - 17:55
(8) тогда бред получается мне же нужно вызвать из модуля формы списка/документа обработчик из модуля менеджера...
   FIXXXL
 
10 - 18.06.20 - 18:11
(7) где смотрел?
в модуле менеджера документа всё прописано? Добавление команд? Сама Печать?
   lirt82
 
11 - 18.06.20 - 18:13
(10) Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт
    
    КомандаПечати = КомандыПечати.Добавить();
    КомандаПечати.МенеджерПечати = "Документ.Расш1_ТранспортнаяНакладная";
    КомандаПечати.Идентификатор = "ТТН";
    КомандаПечати.Представление = НСтр("ru = 'Товарно-транспортная накладная'");
    КомандаПечати.Обработчик    = "УправлениеПечатьюБККлиент.ВыполнитьКомандуПечати";
    КомандаПечати.ПроверкаПроведенияПередПечатью = НЕ ПользователиБКВызовСервераПовтИсп.РазрешитьПечатьНепроведенныхДокументов();
            
КонецПроцедуры

// Формирует печатные формы.

//
// Параметры:

//  МассивОбъектов  - Массив    - ссылки на объекты, которые нужно распечатать;
//  ПараметрыПечати - Структура - дополнительные настройки печати;

//  КоллекцияПечатныхФорм - ТаблицаЗначений - сформированные табличные документы (выходной параметр)
//  ОбъектыПечати         - СписокЗначений  - значение - ссылка на объект;

//                                            представление - имя области в которой был выведен объект (выходной параметр);
//  ПараметрыВывода       - Структура       - дополнительные параметры сформированных табличных документов (выходной параметр).

//
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ТТН",
            НСтр("ru = 'Товарно-транспортная накладная'"),
            ПечатьТТН(МассивОбъектов, ОбъектыПечати),, "Документ.Расш1_ТранспортнаяНакладная.ПФ_MXL_ТТН");
        
КонецПроцедуры

Функция ПечатьТТН(МассивОбъектов, ОбъектыПечати) Экспорт
    
    УстановитьПривилегированныйРежим(Истина);
    
    Макет = УправлениеПечатью.МакетПечатнойФормы("Документ.Расш1_ТранспортнаяНакладная.ПФ_MXL_ТТН");
    
    ТабДокумент = Новый ТабличныйДокумент;
    ТабДокумент.КлючПараметровПечати = "ТТН";
   lirt82
 
12 - 18.06.20 - 18:26
прикол, в форме списка моего дока в расширении поставил точку останова, отладчик даже ее не ловит....

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
   (тут) ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
        
КонецПроцедуры
   AlvlSpb
 
13 - 18.06.20 - 19:39
(12) Приведенный код - это код из расширения? Процедура в расширении не может иметь то же имя что в основной конфе.
   lirt82
 
14 - 19.06.20 - 04:39
(13) все отладка работает
Запустить предприятия с ключом командной строки – ” /C РежимОтладки “
В режиме конфигуратора установить параметр запуска:
Сервис -> Параметры -> Запуск 1С:Предприятия -> Параметр запуска: ввести строку <РежимОтладки>
   lirt82
 
15 - 19.06.20 - 04:41
вопрос решен) незнаю почему но я ничего не менял, просто отладкой прошелся по процедуре и кнопка появилась в подменю))

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.