Вход | Регистрация
 

Обрабатывать каждый N документ?

Обрабатывать каждый N документ?
Я
   Radion
 
17.06.20 - 01:14
Подскажите как правильно реализовать такую задачу. Требуется обрабатывать каждый N (интерактивно задается пользователем) документ. Работает обработка в фоновом режиме, которая обрабатывает документы по алгоритму № 1, и каждый N к примеру 5-й документ обрабатывается по алгоритму № 2. Как возможно это реализовать грамотно? Спасибо.
   Ненавижу 1С
 
1 - 17.06.20 - 01:23
Нужен числовой счетчик
   Radion
 
2 - 17.06.20 - 01:34
(1) на основании регистра сведений?
   Ненавижу 1С
 
3 - 17.06.20 - 01:43
(2) на основании переменной
   Злопчинский
 
4 - 17.06.20 - 02:19
(0) типа:
сч=0;
Пока ВыборкаДокументов Цикл сч = сч + 1;
  Если сч=5 
  Тогда сч=0; ОбработатьДокументАлгоритм2;
  Иначе ОбработатьДокументАлгоритм1;
  КонецЕсли;
КонецЦикла;
   Radion
 
5 - 17.06.20 - 03:26
(4) если бы это к примеру выполнялось раз в день, то наверное прошло бы. если работает регламентное задание - при первом вызове получилось 3 документа, при втором 1, при третьем сработало наше условие по алгоритму № 2 (т.к. это 5-й документ), НО ПОСЛЕ ЭТОГО СЧЕТЧИК ДОЛЖЕН СБРОСИТЬСЯ!!! Мы начинаем опять/снова считать документы в каждом регламентном задании.
   Галахад
 
6 - 17.06.20 - 04:33
Хм. А сразу в регистр нельзя написать?
Обрабатываем вот такие документы, такие-то по такому-то алгоритму. Обработанные помечать.

РС
  Документ
  Алгоритм
  Обработан
   Злопчинский
 
7 - 17.06.20 - 22:46
(5) Фоновый режим и регламентное задание - это сильно общее. хз что у вас там как делится по регламентам и фонам.
   Злопчинский
 
8 - 17.06.20 - 22:48
(5) "НО ПОСЛЕ ЭТОГО СЧЕТЧИК ДОЛЖЕН СБРОСИТЬСЯ!!!" - мы тут что, тебе код написать должны? вариантов решения - вагон. я хз какое из них в идеологии 8-ки является правильным. самое тупое - сделать счетчик доступным между разными сеансами регламентного/фонового задания...
   Aleksey
 
9 - 17.06.20 - 23:05
(5)
Если ВсегоОбработаноДокументов % 5 = 0 тогда
//Алгоритм 2 пришло твое время

Иначе
//ну тут все скучно

КонецЕсли;
   BeerHelpsMeWin
 
10 - 17.06.20 - 23:13
кстати, что должно произойти, если во время обработки X документов придут из другого узла РИБ и Y документов будут изменены другим пользователем?

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.