Вход | Регистрация
 
О жизни... :: Забегаловка

OFF: WildHare пишет книгу

OFF: WildHare пишет книгу
Я
   trad
 
16.06.20 - 17:34
Не являюсь посетителем ИСа.
Но коллеги линканули заметку, нет, не про Никиту, а про другого, широко известного одинесника - Сашу Орефкова.
http://catalog.mista.ru/journal/news/mir-1s/aleksandr-orefkov-prisoedinilsya-k-komande-infostart_1251443/

А через это, набрел на интервью с Никитой
http://catalog.mista.ru/journal/news/mir-1s/nikita-zaytsev-a-k-a-wildhare-ya-universalnyy-soldat-v-mire-1s_1250753/
и на первую часть его книги
http://catalog.mista.ru/public/1246946/

WildHare и сайт hare.ru у меня ассоциирован с началом моей трудовой деятельности, как первая площадка профессионального общения. Когда был молод, здоров, и голоден до работы.
   orefkov
 
1 - 16.06.20 - 17:39
Ну, я сам с сайта Дикого Зайца начинал осваивать 1С. Золотое время :)
   Ёпрст
 
2 - 16.06.20 - 17:41
(1) Когда там снегопат допилишь ? Работа идёт ?
   Ёпрст
 
3 - 16.06.20 - 17:44
посмотрел новость, 8.3.13...а на более старших, заведётся ? на 15, к примеру
   orefkov
 
4 - 16.06.20 - 17:47
(2)
Без комментариев.
(3)
Официальный релиз снегопата пока до 8.3.11.
Следите за новостями...
Так-то я уже два месяца в ИС работаю, вот, теперь и всем рассказали.
   Ёпрст
 
5 - 16.06.20 - 17:51
(4) а чего там делаешь то хоть ?
Это и есть то, о чем раньше говорил, что будешь на работе снегопат пилить ? ;)
   orefkov
 
6 - 16.06.20 - 18:05
(5)
Ну если вкратце, то да.
   Ёпрст
 
7 - 16.06.20 - 18:06
(6) Красота, ждём релизов, пили быстрее
   mistеr
 
8 - 16.06.20 - 18:43
(5) Предположу, что создает имидж ИС :)
   mistеr
 
9 - 16.06.20 - 18:44
(6) Были ли какие-то договоренности о правах на результаты работы?
   orefkov
 
10 - 16.06.20 - 19:14
(9)
Да, конечно. Исключительные права на Снегопат остаются за мной.
   Garykom
 
11 - 16.06.20 - 19:52
(0) Начало книжки хорошо.

Проблема что за "Не спеша, эффективно и правильно" не готовы платить.

А "Быстро и криво" - это франчи и проектные офисы. Особенно с аджайлом и скрамом.
Когда каждый спринт переделывают с матами то что нахерачили на предыдущем.

Но у водопада (типа "Не спеша, эффективно и правильно") другая проблема - легко вырождается в ИБД без контроля или результат как на известной картинке http://3.bp.blogspot.com/_UWPsw_DgfYM/R4EmhL6j4CI/AAAAAAAAAkA/vGL51gB64fg/s1600/realizat.gif
   trad
 
12 - 16.06.20 - 20:11
(11) ну не обязательно что картинка соответствует "не спеша и качественно"
Ведь кроме "быстро и криво" есть ещё "долго и криво"
Ибо когда говорят "из быстро, качественно, дёшево выберите два" речь ведут о максимуме. Можно же выбрать и один и ноль
   Garykom
 
13 - 16.06.20 - 20:31
(12) Угу "быстро и дешево" никогда не бывает качественно ))

Кстати имхо спешка или быстро не совсем верный термин.
Правильнее сказать не достаточно продуманность/спланированность.
Когда решают сиюминутные проблемы не думая о будущем.
   Cthulhu
 
14 - 16.06.20 - 21:49
(10): бывают авторское право, исключительные имущественные права и неисключительные имущественные права.
ели тебе сказали только "исключительные" - есть серьезное опасение, что тебя тупи в лоб напаривают. ну или ты ошибся в формулировке?........
   spock
 
15 - 16.06.20 - 22:12
даёмоё, что со зрением случилось??

Кто знает детали - восстановимо?
   mistеr
 
16 - 17.06.20 - 02:21
(10) Это радует.

И косвенно подтверждает (8) :)
   sTOd
 
17 - 17.06.20 - 07:42
(0) Не думаю что его размышлизмы кому-то будут интересны.
   trad
 
18 - 17.06.20 - 07:58
(17) мне интересны
Конечно, Америк не открывает, но почитать формулировки мыслей интересно.
   mikecool
 
19 - 17.06.20 - 08:12
(0) кто все эти люди?
   Волшебник
 
Модератор
20 - 17.06.20 - 08:13
(19) Это же легенды!
   vi0
 
21 - 17.06.20 - 08:15
потерял зрение заяц.. да, печально это
   Волшебник
 
Модератор
22 - 17.06.20 - 08:16
(21) А вот это непонятно. Чёрные очки, белая трость. Что случилось?
   vi0
 
23 - 17.06.20 - 08:17
(22) там в интервью он ответил
   NorthWind
 
24 - 17.06.20 - 08:28
(23) обалдеть. Сколько же фанатизма надо иметь чтобы так работать...
   fisher
 
25 - 17.06.20 - 09:01
Фига себе! Легенда на радаре!
Обязательно посмотрю-почитаю.
   fisher
 
26 - 17.06.20 - 09:17
Офигеть! Фигурнов - технический писатель в 1С!
Зайцу - лучиков. Очень жаль, что здоровье подорвал.
А зрение - это вообще пипец.
   vi0
 
27 - 17.06.20 - 09:23
(26) Фигурнов - знаем такую фамилию
   fisher
 
28 - 17.06.20 - 09:49
(27) WildHare - Никита Зайцев. Фигурнова он в интервью упоминает. Что видел его в 1С.
   vi0
 
29 - 17.06.20 - 09:51
(28) я понял
я к тому что читал книжку его в студенчестве
   Ёпрст
 
30 - 17.06.20 - 09:53
Фигурнов да, одна из первых книжек..
 
 Рекламное место пустует
   Ёпрст
 
31 - 17.06.20 - 09:53
Потеря зрения..это полный пэ
   vovastar
 
32 - 17.06.20 - 10:00
Карантин открыл новые стремления у людей.
   fisher
 
33 - 17.06.20 - 10:18
Зайцев стоял у истоков формирования сообщества одинэсников. Можно сказать, сам был одним из истоков. Настоящий профессионал, на которых стоит равняться. Я в те времена только первые шаги в 1С делал и в тусовке почти не участвовал. Но наблюдал пристально. На заре зарождения сообщества 1С атмосфера была очень самобытной и профессиональной. Семерка к этому располагала :) Ибо документация на первых порах была доступна только в бумаге из коробочных поставок и при этом помогала так себе. Плюс вообще был информационный голод решительно по всем вопросам, не только 1С. Не чета сегодняшней шаре, где протянул руку - и бери что угодно. Так и то ленятся. "Загуглите мне послеобеденные видеоролики по такой-то теме, чтобы я за чаем стал профессионалом и дайте подборку ссылок, а то я сам не могу придумать что в гугл вбивать, мозговой ручник заржавел за ненадобностью". А тогда были рады раздобыть любые крупицы информации. Царила атмосфера совместного первооткрывательства, которая дарила сильное ощущение причастности к сообществу. Кто застал те времена, наверняка по ним скучает.
   Глобальный_Поиск
 
34 - 17.06.20 - 10:30
(33) просто вы уже постарели и ностальгируете по молодости. Когда был полон энтузиазма и забесплатно был готов сутками от компа не отрываться, просто потому что интересно. А щас небось бесплатно не то что зад с кресла не поднимешь, а даже на монитор не глянешь.
   fisher
 
36 - 17.06.20 - 10:37
(34) И это тоже. В части "трава зеленее". Энтузиазма ессно поубавилось, но интерес который привел меня в ИТ угасать не собирается. Это ж блин прикольно все!
   vovastar
 
37 - 17.06.20 - 10:40
(34) поддерживаю. Достаточно показателен пример Мани, который создал что то и думал что будет всю оставшуюся жизнь получать дивиденты. А не тут то было. Мир не стоит на месте, надо двигаться всегда.  Да таких примеров много, жаль нельзя их обсудить здесь.
   vovastar
 
38 - 17.06.20 - 10:43
+(37) и кто бы не говорил про информационный голод, в клюшках все равно было легче ориентироваться...да и знать надо было намного меньше..
   fisher
 
40 - 17.06.20 - 10:46
Я вообще не представляю, как можно работать в ИТ, если нет интереса. Сплошное расстройство. Сразу из оптимиста, который на любые нововведения реагирует "ухтышка, новый подарок завезли, давай распакуем!!!" превращаешься в брюзгу "вот блин опять новую хрень изучать, чем старое плохо было?".
   sTOd
 
41 - 17.06.20 - 10:50
(18) Дай ему автограф. Ты ведь единственный.
   Глобальный_Поиск
 
42 - 17.06.20 - 10:52
(40) чорт. А ведь я в последнее время чаще второе, чем первое.
   ptiz
 
43 - 17.06.20 - 11:01
(0) Про лифты в книге прям классно :)
Думаю, всем приятно почитать подтверждение простой мысли, что долго и качественно - это лучше, чем быстро и кое-как. И что эта мысль часто не доходит до руководителей.
Но, по-факту, 95% фирм содержат специалиста "тыжодиэсник", который на все руки мастер.
   fisher
 
44 - 17.06.20 - 11:03
(38) Да нифига в семерке было не легче. В семерке было сложнее. Она была менее прозрачна и вызывала кучу wtf. Это когда уже на каждую хитрую гайку приготовлен хрен с винтом, вот тогда уже легко. Концептуально восьмерка не глубже. Она просто шире. Зато гораздо более прозрачна.
   orefkov
 
46 - 17.06.20 - 11:06
(40)
Ну как-раз у Никиты в этой книге написано:
"Абсолютное большинство пользователей ненавидит обновление, которое привносит в систему ненужные им функции, но не привносит исправление старых ошибок"
   ptiz
 
47 - 17.06.20 - 11:12
(44) Хорошо сказано. Язык и объектная модель в 8ке прозрачнее, это точно. Только "широта" давно превзошла размера мозга одного 1Сника. Вот даже не знаю, хорошо это или нет. С одной стороны - хорошо, инструментов море, с другой - качественно работать с ними может только команда под руководством настоящего Эксперта. А их на каждую организацию не напасешься.
   fisher
 
48 - 17.06.20 - 11:20
А еще вспомнить, что в 7.7 не было конструктора отчетности, что требовало сразу на старте у любого новичка каких-то элементарных навыков программирования. А написать универсальный отчет с богатыми пользовательскими настройками было уже не очень тривиальной задачей. Сейчас на 8-ке многие новички успешно юзают СКД и при этом еще долго не в состоянии написать что-то сложнее линейного "Если Тогда".
Тогда что можно сказать, что порог входа понизился :)
   vovastar
 
49 - 17.06.20 - 11:21
(44) толи мы стареем, толи голова думать не дает. Клюшка мне далась с одного дыхания, на восьмерке очень частые затыки, поэтому сложные задачи на фриланс.
   fisher
 
50 - 17.06.20 - 11:23
(49) Сами прикладные решения усложнились. Но не из-за усложнения платформы, а в силу эволюции. Платформа просто дала возможности для такого масштабирования.
   fisher
 
51 - 17.06.20 - 11:26
Многие вспоминают "на клюшках было легче" именно в силу того, что большинство решений на клюшках были примитивными.
   trad
 
52 - 17.06.20 - 11:30
(51) +1
   vovastar
 
53 - 17.06.20 - 11:31
(51) да ну. Для своего времени, Семерка была инновационной. Достаточно вспомнить Парус например. Даже тогда 1С была на голову выше конкурентов.
   Волшебник
 
Модератор
54 - 17.06.20 - 11:50
(23)

>>
Вопрос, возможно, нескромный. Что послужило причиной ухода из «1С»?

Есть такая старая добрая советская формулировка: «По состоянию здоровья». Сказался образ и ритм жизни. Двадцать три года работы в ломовом режиме, ну и отдых от работы, когда он случался, тоже проходил не на пляже под пальмой, как говорят в народе – укатали сивку крутые горки. Уже не мог работать с полной нагрузкой, серьезные задачи тянуть уже не получалось. Поэтому пришлось уйти.

Дальше были попытки как-то восстановить здоровье, но не совсем удачные. В сухом остатке – почти полная потеря зрения, ну и еще всякое, без подробностей. Это было вполне ожидаемо, просто ресурс оказался выработан чуть раньше расчетного времени. Что поделать? Ничего страшного в этом нет.
>>
   такт
 
55 - 17.06.20 - 11:52
Главный вывод из интервью Никиты - не стоит полностью замещать жизнь работой.
   fisher
 
56 - 17.06.20 - 12:07
(55) Никита такого вывода не делает. Жизнь закончится в любом случае. Это конечный ресурс. Если ты чувствуешь себя максимально живым вкалывая - вкалывай. В этом больше смысла, чем как-то специально себя беречь. Перед смертью не надышишься.
   такт
 
57 - 17.06.20 - 12:19
(56) это был мой вывод
кстати - если у Никиты был Эксперт из первой десятки, то у меня из второго десятка
и зрение тоже поплыло, но я вовремя сбавил обороты и стал просто жить и работать не более 8 часов в день
   fisher
 
58 - 17.06.20 - 12:28
Ну, редко кто способен так надорваться, потому что редко кто так вкалывает. Организм все же обычно включает защитные механизмы. Они притупляются только если продолжать вкалывать, а на это нужны сила и воля. Никита продолжал вкалывать десятилетиями. Мой вывод - я размазня на фоне Никиты.
   vovastar
 
59 - 17.06.20 - 12:33
(57) Есть еще такой тип людей, которые очень и очень сильно переживают за конечный результат своего труда. А нервный стресс в совокупности с усталостью приводит к очень плачевным результатам. А если туда еще добавить и спиртные напитки, то организм откажет.
До 35 я тоже жил работой и переживал, а потом как хреново стало, врачи сказали Вова, хватит....вовремя остановился. Теперь и дневной сон, да и как то по другому на жизнь стал смотреть. Даже хотел уйти на постоянку, но как то на дядю колымить не смогу...
   VladZ
 
60 - 17.06.20 - 12:53
(0) До конца не дочитал, но позволю себе высказать несколько замечаний:

Важное замечание, которое я не увидел: У любой задачи есть срок актуальности.

Работал я как-то в одной очень динамичной компании.
Чтобы понимать, что это такое, приведу пример: наш отдел взял пул задач по автоматизации производственных процессов. С руководством согласовали срок - 3 месяца.
Проходит два месяца. Вызывает нас руководство и говорит: "Ребята, что-то мне не нравится что у нас нет своих розничных точек. Давайте развивать свою розничную сеть!" И бросает наш отдел на розницу. Прошлый проект с нас никто не снимал. Типо "заканчивайте в фоновом режиме". Проходит еще какое-то время - нас бросают на другой проект.

К чему это всё я описываю? А к тому, что "долго и правильно" - это хороший подход. Но, он работает не для всех задач. Можно делать "долго и правильно", но на момент выхода ИТ-продукта задача уже "протухнет". Она уже будет неактуальна!

Поэтому, нельзя разделять подход к задачам на "черное и белое". Где-то нужно сделать быстро и с заданным уровнем качества (не обязательно идеально). Где-то "долго и правильно".
 
 Рекламное место пустует
   VladZ
 
61 - 17.06.20 - 12:57
+60. Кстати, обратите внимание на компанию 1с. На выходе всегда продукт идеального качества? Нет, конечно.
Но 1с (насколько я понимаю) и не стремится к этому. У компании 1С задача "выпустить продукт к заданному сроку с заданным уровнем качества" (заметьте, тут нет понятия "Идеального качества").
   vovastar
 
62 - 17.06.20 - 13:02
(61) а где Вы видели продукт идеального качества? Даже Винду уже сколько пилят, пилят...и все никак...
   fisher
 
63 - 17.06.20 - 13:17
(60) Я книгу еще не читал. Но чем более требователен продукт (например, высокая нагрузка) тем более квалифицированного инженерного подхода он требует и тем меньше он прощает ошибки. Тут именно что проекты и специалисты "притягиваются". Хорошие инженеры в итоге попадают на сложные продукты, где их "правильность" окупается сторицей и приносит деньги бизнесу, а менее квалифицированные - на более раздолбайские, где "и так сойдет". Какие причины задерживаться хорошему инженеру на раздолбайских продуктах, не реализовывая свой потенциал? Только если выбора нет или квалификация не позволяет.
   palsergeich
 
64 - 17.06.20 - 13:28
(55) Соглашусь.
Я тоже 4 года работал в режиме нонстоп, отличная карьера.
Но потом начал чувствовать что сдаю. Прям пару раз звоночек прозвенел.
Послал все лесом и сейчас стараюсь не прыгать выше физиологии.
   Cthulhu
 
65 - 17.06.20 - 13:52
(29): врешь.
"И каково же было мое удивление, когда в первый же рабочий день на пятом этаже Д9 я встретил Виктора Эвальдовича в качестве технического писателя Технологии 1cFresh. В документации на некоторые релизы Технологии можно встретить такое указание авторства – «В. Фигурнов, Н. Зайцев»."
(с)
   Cthulhu
 
66 - 17.06.20 - 13:53
(65) к (28) конечно, пардон.
   vi0
 
67 - 18.06.20 - 10:35
(65) не понял, вру в чем?
   vi0
 
68 - 18.06.20 - 10:35
(66) а
   vi0
 
69 - 18.06.20 - 10:45
(34) все таки то время было немного другое, в том плане что сейчас все на ладони
хотя это опять же лично с моей точки зрения
но объективно - тогда то и вакансий особо не было на другие языки
   vi0
 
70 - 18.06.20 - 10:54
(38) легче, но из за убогости клюшек я собирался уйти из 1с, но в тот момент вышла восьмерка
   trad
 
71 - 14.07.20 - 11:17
Часть 2. Теория
https://clck.ru/PeZ2a

Часть 3. Практика
https://clck.ru/PeZ4g
   Новый участник
 
72 - 14.07.20 - 11:30
(62) Toyota Crown и топовые машины начала века.
   Злопчинский
 
73 - 14.07.20 - 11:54
(64) оооо люди по несколько лет... я вностопе проработал квартал и решил - ну его нафиг, жизнь мимо проходит...
   Злопчинский
 
74 - 14.07.20 - 12:16
ннасчет основного постулата книги - интересно что orefkov скажет, по несколько  обновлений в день выпускает..;-) неспешно... ;-)
   Злопчинский
 
75 - 14.07.20 - 12:30
Ненавижу такие конструкции, типа

Процедура ЧтоТо(Параметры)

Если ПустоеЗначение(Параметры)=1 Тогда //мля, интерсено а там дальше будет ветка иначе? а после если будет что-то использующее вычисляемое в если - ХРЕН ЗНАЕТ!
    //тут делаем много хрени всякой на экран а то и больше
КонецЕсли;

КонецПроцедуры

Еще это усугубляется когда несколько "если" вложенных и получается..

    КонецЕсли;
  КонецЕсли;

КонецПроцедуры

Пока до конца если дойдешь уже забыл что к чему относится.
стараюсь код линеаризировать по возможности, избавляясь от куч если

Процедура ЧтоТо(Параметры)

Если ПустоеЗначение(Параметры)=0 Тогда Возврат; КонецЕсли;
//линейный код далее без лестниц если

КонецПроцедуры
   Злопчинский
 
76 - 14.07.20 - 14:21
Возьмем например типовую
.
//******************************************************************************
// глНайтиСчетФактуру(Конт,ВидСФ,ВозврПомУд)
//
// Параметры:
//     Конт        - текущий контекст формы документа
//     ВидСФ        - (Строка) - название вида документа (счета фактуры)
//  ВозврПомУд    - 1 - возвращать и помеченный на удаление СФ, 0 - не возвращать.
//                Значение по умолчанию 1.
//
// Возвращаемое значение:  
//  Найденный счет-фактура или ""
//
// Описание:
//     Функция ищет счет-фактуру документа среди подчиненных документов
//
Функция глНайтиСчетФактуру(Конт,ВидСФ,ВозврПомУд=1) Экспорт
    Перем ДокПодч;
    
    СФПомНаУд    = "";
    
    // проверяем чтобы был записан всегда!
    Если (Конт.Выбран() = 1) Тогда
        
        ДокПодч    = СоздатьОбъект("Документ");
        ДокПодч.ВыбратьПодчиненныеДокументы(,,Конт.ТекущийДокумент());
        
        Пока  ДокПодч.ПолучитьДокумент()=1 Цикл
            Если ДокПодч.Вид() = ВидСФ Тогда
                ТекСФ    = ДокПодч.ТекущийДокумент();
                
                Если ТекСФ.ПометкаУдаления() = 1 Тогда
                    Если (ПустоеЗначение(СФПомНаУд) = 1) И (ВозврПомУд = 1) Тогда
                        СФПомНаУд    = ТекСФ;
                    КонецЕсли;
                Иначе
                    Возврат ТекСФ;
                КонецЕсли;
                
            КонецЕсли;
        КонецЦикла;
        
    КонецЕсли;
    
    Возврат СФПомНаУд;
    
КонецФункции // глНайтиСчетФактуру()
   Злопчинский
 
77 - 14.07.20 - 14:22
Это ж капец, мозг сломать можно..
   Злопчинский
 
78 - 14.07.20 - 14:26
Функция глНайтиСчетФактуру(Конт,ВидСФ,ВозврПомУд=1) Экспорт
  Перем ДокПодч;
    
  СФПомНаУд = "";
  Если Конт.Выбран() = 0 Тогда Возврат СФПомНаУд = ""; КонецЕсли; // проверяем чтобы был записан всегда!
        
  ДокПодч = СоздатьОбъект("Документ");
  ДокПодч.ВыбратьПодчиненныеДокументы(,,Конт.ТекущийДокумент());
    
  Пока  ДокПодч.ПолучитьДокумент()=1 Цикл
    Если ДокПодч.Вид() <>= ВидСФ Тогда Продолжить; КонецЕсли;

    ТекСФ = ДокПодч.ТекущийДокумент();
    Если ТекСФ.ПометкаУдаления() = 0 Тогда Возврат ТекСФ; КонецЕсли;

    Если (ПустоеЗначение(СФПомНаУд) = 1) И (ВозврПомУд = 1) Тогда
    СФПомНаУд = ТекСФ;
    КонецЕсли;
  КонецЦикла;
    
  Возврат СФПомНаУд;
    
КонецФункции // глНайтиСчетФактуру()
   Злопчинский
 
79 - 14.07.20 - 14:27
так - не лучше?
   trad
 
80 - 14.07.20 - 14:43
Если ТекСФ.ПометкаУдаления() = 0 Тогда Возврат ТекСФ; КонецЕсли;


- десять лет расстрела без права переписки
   Злопчинский
 
81 - 14.07.20 - 23:41
(80) за что?!
   orefkov
 
82 - 15.07.20 - 00:16
(74)
У меня там своя атмосфера :)
   trad
 
83 - 15.07.20 - 09:58
(81) за блочный оператор в одну строку
   Конструктор1С
 
84 - 15.07.20 - 10:09
(11) на самом деле "быстро+криво=дешево" - одна из самых больших иллюзий в нашей отрасли. Кривые поделки обходятся заказчику дороже. Не сразу, но заказчик за быстрошлёпные поделки сильно переплатит. Они обойдутся ему дороже, чем если бы сразу всё делалось на совесть. А самая большая проблема в том, что даже среди программистов не многие понимают дороговизну бренда Быстро&Криво...
   orefkov
 
85 - 15.07.20 - 10:52
(81) (83)
Там еще и запяточка между ТекСФ и КонецЕсли лишняя! Перерасход.
   orefkov
 
86 - 15.07.20 - 10:55
(84)
Как говорится - "Зачем вы тянете до последнего, а потом впопыхах делаете криво? Делайте криво сразу - тогда еще останется время переделать"
   Волшебник
 
87 - 15.07.20 - 11:21
(86) Золотые слова!
   Злопчинский
 
88 - 15.07.20 - 11:47
(85) запяточки - я вот ненавижу когда
Если аааа
  ч=а
КонецЕсли;

если ставить запяточки - то ставить всегда.
ибо нехрен моз ломать.
   Злопчинский
 
89 - 15.07.20 - 11:50
(83) нормально все. в блоке один элементарный оператор. атомарный, блин.
мне так читается легче когда простейшие конструкции в одну строку "Посмотрел - и все понятно!"
а скакать по одно этажным лесенкам - нахера такое надо? ты же скамейку-ступеньку не ставишь чтобы на диван залезть...
.
если блочный оператор внутри больше кода содержит - тогда пишу лесенкой...
   Злопчинский
 
90 - 15.07.20 - 11:51
(84) в целом - да. на практике - херня часто. "быстро и дешево" среди всего комплекта который есть в бизнесе - далеко не самая проблемная вещь.
   trad
 
91 - 15.07.20 - 12:09
(89) во-первых, код легче воспринимается когда блочные конструкции всегда блочные (тыж запяточки всегда ставишь )) ибо нехрен моз ломать)
во-вторых, при отладке я буду знать, что сейчас выполнится этот "один элементарный оператор. атомарный" не вычисляя выражение условия в уме
   trad
 
92 - 15.07.20 - 12:21


Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.
В секцию Забегаловка можно добавлять сообщения только через 7 днейпосле регистрации на форуме.
Если вы уже зарегистрированы, вам нужно войти на форум.