Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Печатная форма недоступна ЗУП 3.1

Печатная форма недоступна ЗУП 3.1
Я
   Filkkore
 
16.06.20 - 07:56
ЗУП 3.1.14.55

Впервые использую модуль КадровыйУчет, видимо ещё не совсем понимаю как это работает, ну или вообще везде накосячил :^)
При попытке вывести это чудо пишет "Печатная форма недоступна".

КОД:

Функция ЗапросДляПечати(МассивОбъектов, ОбъектыПечати)
    
    ТабДок = Новый ТабличныйДокумент;
    
    Запрос = Новый Запрос;
    
    Запрос.МенеджерВременныхТаблиц = Новый МенеджерВременныхТаблиц;
    
    Запрос.Текст =
        "ВЫБРАТЬ
        |    Сотрудники.Ссылка КАК Ссылка,
        |    Сотрудники.Ссылка.Номер КАК Номер,
        |    Сотрудники.Ссылка.Дата КАК Дата,
        |    Сотрудники.Ссылка.Дата КАК Период,
        |    Сотрудники.НомерСтроки КАК НомерСтроки,
        |    Сотрудники.Сотрудник КАК ФизическоеЛицо,
        |    ВЫБОР
        |        КОГДА Сотрудники.Сотрудник.Пол = ЗНАЧЕНИЕ(Перечисление.ПолФизическогоЛица.Мужской)
        |            ТОГДА 1
        |        ИНАЧЕ 2
        |    КОНЕЦ КАК Пол,
        |    Сотрудники.ВидЗаявления КАК ВидЗаявления,
        |    ОсновныеСотрудникиФизическихЛиц.Сотрудник КАК Сотрудник
        |ПОМЕСТИТЬ ВТДанныеДокументов
        |ИЗ
        |    Документ.ЗаявленияОПредоставленииСведенийОТрудовойДеятельности.Сотрудники КАК Сотрудники
        |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСотрудникиФизическихЛиц КАК ОсновныеСотрудникиФизическихЛиц
        |        ПО Сотрудники.Сотрудник = ОсновныеСотрудникиФизическихЛиц.ФизическоеЛицо
        |            И Сотрудники.Ссылка.Организация.ГоловнаяОрганизация = ОсновныеСотрудникиФизическихЛиц.ГоловнаяОрганизация
        |            И (Сотрудники.Ссылка.Дата МЕЖДУ ОсновныеСотрудникиФизическихЛиц.ДатаНачала И ОсновныеСотрудникиФизическихЛиц.ДатаОкончания)";
        
    Запрос.Выполнить();
    
    Описатель = КадровыйУчет.ОписательВременныхТаблицДляСоздатьВТКадровыеДанныеСотрудников(
    Запрос.МенеджерВременныхТаблиц, "ВТДанныеДокументов", "Сотрудник,Период");
    
    Описатель.ИмяВТКадровыеДанныеСотрудников = "ВТКадровыеДанныеСотрудниковДляЗаявления";
    КадровыйУчет.СоздатьВТКадровыеДанныеСотрудников(Описатель, Истина, "Должность,ФИОПолные,ИОФамилия,Фамилия");
    
    Запрос.Текст =
        "ВЫБРАТЬ
        |    КадровыеДанныеСотрудников.ИОФамилия КАК ИОФамилия,
        |    КадровыеДанныеСотрудников.Период КАК Период,
        |    КадровыеДанныеСотрудников.Должность КАК Должность,
        |    КадровыеДанныеСотрудников.ФИОПолные КАК ФИОПолные,
        |    КадровыеДанныеСотрудников.Фамилия КАК Фамилия,
        |    КадровыеДанныеСотрудников.Сотрудник КАК Сотрудник,
        |    КадровыеДанныеСотрудников.Должность.Наименование КАК Наименование
        |ИЗ
        |    ВТДанныеДокументов КАК ДанныеДокументов
        |        ЛЕВОЕ СОЕДИНЕНИЕ ВТКадровыеДанныеСотрудниковДляЗаявления КАК КадровыеДанныеСотрудников
        |        ПО ДанныеДокументов.Период = КадровыеДанныеСотрудников.Период
        |            И ДанныеДокументов.Сотрудник = КадровыеДанныеСотрудников.Сотрудник";
    
    
    Выборка = Запрос.Выполнить().Выбрать();
    
    Макет = ПолучитьМакет("Макет");
    
    ОбластьДокумент = Макет.ПолучитьОбласть("Документ");
    
    ОбластьДокумент.Параметры.Должность = Выборка.Должность;
    ОбластьДокумент.Параметры.ФИОСотрудника = Выборка.ФИОПолные;
    Макет.Вывести(ОбластьДокумент);
    
    Возврат ТабДок;
    
КонецФункции

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ЭТК") Тогда
    
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ЭТК",
        "Заявления о предоставлении сведений о трудовой деятельности (внешняя печатная форма)",
        ЗапросДляПечати(МассивОбъектов, ОбъектыПечати),,"Макет");
    
    КонецЕсли;

КонецПроцедуры
   МимохожийОднако
 
1 - 16.06.20 - 08:29
(0) Объясни эту строку 
  Макет.Вывести(ОбластьДокумент);
   Filkkore
 
2 - 16.06.20 - 08:31
(1) О Господи я слепой дурак....

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.