Вход | Регистрация
 

Универсальная работа с общим реквизитом в регистре сведений

Универсальная работа с общим реквизитом в регистре сведений
Я
   baglandir111
 
15.06.20 - 10:17
Есть общий реквизит "T"  для некоторых регистров сведений.

Необходимо с помощю внешнего события сделать универсальную функцию,
которая будет заполнять этот реквизит "текущей датой" при записи регистра сведений.

В документе все очень просто :


Процедура T_DocumentПриЗаписи(Источник, Отказ) Экспорт
    
    Если Отказ = ложь Тогда  
        
        
            Источник.T = ТекущаяДата();    
        
        
    КонецЕсли;

КонецПроцедуры

Не пойму как сделать в регистре чтобы не нужно было писать описания и отборы по каждому регистру сведений.
   azt-yur
 
1 - 15.06.20 - 10:21
(0) Подпиской на событие Перед записью для всех твоих регистров
   baglandir111
 
2 - 15.06.20 - 10:22
(0) понятно что подпиской на события , вопрос не где а как ?
   azt-yur
 
3 - 15.06.20 - 10:23
(2) Ну как то так:

Для Каждого Запись Из Источник Цикл
 Запись.Т = ТекущаяДата();
КонецЦикла;
   baglandir111
 
4 - 15.06.20 - 10:32
(3) Супер ! Благодарю ! Это то что нужно !
   Волшебник
 
Модератор
5 - 15.06.20 - 10:38
(3) Лучше так:

ТекДата = ТекущаяДата();
Для Каждого Запись Из Источник Цикл
 Запись.Т = ТекДата;
КонецЦикла;
   baglandir111
 
6 - 15.06.20 - 11:13
(5) Благодарю !:-)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.