Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Конвертация 2.1: БП 2.0 КОРП->УТ 11 не заполняет Аналитику учета номенклатуры

Конвертация 2.1: БП 2.0 КОРП->УТ 11 не заполняет Аналитику учета номенклатуры
Я
   mikit
 
14.06.20 - 20:17
Бьюсь который день, есть правила типовые БП 2.0 КОРП -> УТ 11, добавила в них выгрузку Поступление товаров и услуг и Реализацию. Документы переносятся, но к сожалению реквизит в табл части товары "АналитикаУчетаНоменклатуры" не заполняется. Пробовала убирать строку (//Объект.ОбменДанными.Загрузка = Истина; ) в глобальном обработчике "После загрузки данных" не помогает

Для Каждого СтрокаТаблицы Из ЗагруженныеОбъекты Цикл

Если СтрокаТаблицы.Объект.ЭтоНовый() Тогда
Продолжить;
КонецЕсли;

Объект = СтрокаТаблицы.Объект.Ссылка.ПолучитьОбъект();
ПараметрыОбъекта = СтрокаТаблицы.Параметры;
ИмяПКО = СтрокаТаблицы.ИмяПКО;

ОбъектМодифицирован = Истина;

Если Метаданные.Справочники.Содержит(Объект.МетаДанные()) Тогда
Выполнить(Алгоритмы.ОбработкаСправочниковОтложенная);
КонецЕсли;

Если Метаданные.Документы.Содержит(Объект.МетаДанные()) Тогда
Выполнить(Алгоритмы.ЗаполнениеДокументовОтложенное);
КонецЕсли;

Если ОбъектМодифицирован Тогда
Объект.ОбменДанными.Отправитель = Параметры.УзелОбменаЗагрузкаДанныхСсылка;
//Объект.ОбменДанными.Загрузка = Истина;
Объект.Записать();
КонецЕсли;

КонецЦикла;
   vicof
 
1 - 14.06.20 - 22:20
И где здесь заполнение аналитики номенклатуры?
   mikit
 
2 - 15.06.20 - 20:36
(1) Заполнение аналитики в модуле объекта. Решение - дописала проведение в ПКО после загрузки Объект.Записать(РежимЗаписиДокумента.Проведение) - аналитика заполняется, но документ не проводится.
Пробую дописать Объект.Проведен=Истина; не срабатывает. Объект загружается непроведенным. (визуально он проведен, но движений нет и в консоли запросов реквизит Проведен = ложь)

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.