Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Из двумерного массива получить структуру по одной колонке

Из двумерного массива получить структуру по одной колонке
Я
   Ilnazio
 
14.06.20 - 17:25
Доброго времени суток! Есть массив из двух колонок, допустим связка продукции и номенклатуры. Нужно получить структуру чисто из одной колонки номенклатуры.

Для каждого стр из НайденныеСтроки Цикл
    Значение = стр.Номенклатура;
    ПараметрыОтбораФормы.Вставить("Номенклатура",Значение);
КонецЦикла;


Такой код затирает предыдущие элементы и на выходе мы получаем только результат последней строки с номенклатурой. Есть идеи?
   МихаилМ
 
1 - 14.06.20 - 17:34
   Ilnazio
 
2 - 14.06.20 - 18:31
(1) Спасибо большое
   Ilnazio
 
3 - 14.06.20 - 19:19
(1) Можешь пожалуйста немного объяснить принцип работы? В СП не нашел инфы..
Банально как работает самый пример который приведет по данной ссылке?

&НаКлиенте
Процедура КомандаОткрытьФормуВыбора(Команда)
 
    ПараметрыВыбора = Новый Структура("РежимВыбора",Истина);

    ОткрытьФорму("Документ.РеализацияТоваровУслуг.ФормаВыбора",ПараметрыВыбора,ЭтаФорма);

КонецПроцедуры

&НаКлиенте
Процедура ОбработкаВыбора(ВыбранноеЗначение, ИсточникВыбора)///Событие формы

    
     РезультатСсылка =  ВыбранноеЗначение;///Выбранное значение, вернет ссылку (документа в нашем примере)


КонецПроцедуры

Окей, команда открывает форму которую прописали внутри первой процедуры. Но каким образом открывается обработка выбора? если мы вызываем форму выбора справочника1, находясь в табличной части встроенной обработки, то каким образом сработает вторая процедура обработки выбора?
   МихаилМ
 
4 - 14.06.20 - 20:04

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.