Вход | Регистрация
 
1С:Предприятие :: 1С:Предприятие 8 общая

Привeдeниe в пoрядoк тeлeфoнных нoмeрoв

Привeдeниe в пoрядoк тeлeфoнных нoмeрoв
Я
   Taugor
 
13.06.20 - 18:50
Всем привет!

Делаю велосипед для приведение в порядок номеров:

    ИсхСтр = СокрЛП(НомерТелефона);
    РезСтр = "";
    Если ИсхСтр <> "" Тогда
        Для Инд = 1 По СтрДлина(ИсхСтр) Цикл
            Симв = Сред(ИсхСтр, Инд, 1);
            Если Найти("0123456789", Симв) = 0 Тогда
                Продолжить;
            КонецЕсли;
            РезСтр = РезСтр + Симв;
        КонецЦикла;
        
        Если СтрДлина(РезСтр) = 10 Тогда
            РезСтр = "+7" + РезСтр;
        КонецЕсли;
        
        Если СтрДлина(РезСтр) = 11 И Лев(РезСтр, 1) = "8" ИЛИ Лев(РезСтр, 1) = "7" Тогда
            РезСтр = "+7" + Сред(РезСтр,2);
        КонецЕсли;
        
        Возврат РезСтр;
        
    КонецЕсли;

Организация работает по РФ, иногда по СНГ.

Подскажите, международный формат номера у всего СНГ состоит из 12 символов?
   МихаилМ
 
1 - 13.06.20 - 18:58
Для Инд = 1 По СтрДлина(ИсхСтр) Цикл
            Симв = Сред(ИсхСтр, Инд, 1);
            Если Найти("0123456789", Симв) = 0 Тогда ...

ИЗЫДИ НЕЧИсТЬ
   Taugor
 
2 - 13.06.20 - 19:10
(1) А что тут не так, поясни?
код брал отсюда http://catalog.mista.ru/public/272923/ у всеми уважаемого Г1С.
   NorthWind
 
3 - 14.06.20 - 14:51
(2) да ничо. Это уже вторая ветка где он на кого-то напал. Агрессивный какой-то
   МихаилМ
 
4 - 14.06.20 - 16:02
(0) извините.
   Tatitutu
 
5 - 14.06.20 - 16:25
(0) приведи к одной длине, а потом через МАСКА приведи к нужному виду.
"у всеми уважаемого" - отлично пошутил!
   DJ Anthon
 
6 - 14.06.20 - 23:05
8800 нельзя заменять на +7800

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.