Вход | Регистрация
 

Запрос не выбирает данные из регистра

Запрос не выбирает данные из регистра
Я
   falselight
 
12.06.20 - 13:25
Подскажите что не так в запросе, нет выборки из регистра.
Выбирает только OzonSkuId.
то есть то что есть в переданной таблице в запрос.

Запрос.Текст = "
    |ВЫБРАТЬ
    |    ПромежуточнаяТЗ.Штрихкод  КАК Штрихкод,
    |    ПромежуточнаяТЗ.OzonSkuId КАК OzonSkuId
    |ПОМЕСТИТЬ ВТ_Промежуточная
    |ИЗ
    |    &ПромежуточнаяТЗ КАК ПромежуточнаяТЗ
    |;
    |
    |////////////////////////////////////////////////////////////////////////////////
    |ВЫБРАТЬ
    |    ВТ_Промежуточная.OzonSkuId           КАК OzonSkuId,
    |    ШтрихкодыНоменклатуры.Штрихкод       КАК Штрихкод,
    |    ШтрихкодыНоменклатуры.Номенклатура   КАК Номенклатура,
    |    ШтрихкодыНоменклатуры.Характеристика КАК Характеристика
    |ИЗ
    |    ВТ_Промежуточная КАК ВТ_Промежуточная
    |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ШтрихкодыНоменклатуры КАК ШтрихкодыНоменклатуры
    |        ПО ВТ_Промежуточная.Штрихкод = ШтрихкодыНоменклатуры.Штрихкод";
Запрос.УстановитьПараметр("ПромежуточнаяТЗ", ПромежуточнаяТЗ);
Рез = Запрос.Выполнить();
Если Не Рез.Пустой() Тогда
    Выборка = Рез.Выбрать();
    Пока Выборка.Следующий() Цикл
        НоваяСтрока = ДанныеДляЗагрузки    .Добавить();
        НоваяСтрока.OzonSkuId      = Выборка.OzonSkuId;
        НоваяСтрока.Штрихкод       = Выборка.Штрихкод;
        НоваяСтрока.Номенклатура   = Выборка.Номенклатура;
        НоваяСтрока.Характеристика = Выборка.Характеристика;
    КонецЦикла;
КонецЕсли;
   falselight
 
1 - 12.06.20 - 13:28
КвалификаторыСтрокиSKU     = Новый КвалификаторыСтроки(9);
    КвалификаторыСтрокиBarcode = Новый КвалификаторыСтроки(13);
    ОписаниеСтрокиSKU          = Новый ОписаниеТипов("Строка", , КвалификаторыСтрокиSKU);
    ОписаниеСтрокиBarcode      = Новый ОписаниеТипов("Строка", , КвалификаторыСтрокиBarcode);
    //

    ПромежуточнаяТЗ = Новый ТаблицаЗначений;
    ПромежуточнаяТЗ.Колонки.Добавить("Штрихкод",  ОписаниеСтрокиSKU);
    ПромежуточнаяТЗ.Колонки.Добавить("OzonSkuId", ОписаниеСтрокиBarcode);
   falselight
 
2 - 12.06.20 - 13:28
Если Табдок.Область("R" + Формат(х,"ЧГ=0")+"C3").Текст <> "0" Тогда
        НоваяСтрока = ПромежуточнаяТЗ.Добавить();
        НоваяСтрока.Штрихкод       = Табдок.Область("R" + Формат(х,"ЧГ=0")+"C5").Текст;
        НоваяСтрока.OzonSkuId      = Табдок.Область("R" + Формат(х,"ЧГ=0")+"C3").Текст;
    КонецЕсли;
   falselight
 
3 - 12.06.20 - 13:40
решил

Список тем форума
Рекламное место пустует  Рекламное место пустует
ВНИМАНИЕ! Если вы потеряли окно ввода сообщения, нажмите Ctrl-F5 или Ctrl-R или кнопку "Обновить" в браузере.